summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-30 13:26:47 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-30 13:26:47 (GMT)
commit966dee2f697dcffe7aa4945854a6168efb76df0d (patch)
tree00c999b75993ac3b108e8c0b29b0b05c933a6080 /abs/core
parentccbca905ebd76c0643ec1e5a06364c428e036566 (diff)
downloadlinhes_pkgbuild-966dee2f697dcffe7aa4945854a6168efb76df0d.zip
linhes_pkgbuild-966dee2f697dcffe7aa4945854a6168efb76df0d.tar.gz
linhes_pkgbuild-966dee2f697dcffe7aa4945854a6168efb76df0d.tar.bz2
python-py: initial inclusion. dep of python-pytest
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/python_modules/python-py/PKGBUILD57
-rw-r--r--abs/core/python_modules/python-py/__changelog1
2 files changed, 58 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-py/PKGBUILD b/abs/core/python_modules/python-py/PKGBUILD
new file mode 100644
index 0000000..d0fec8b
--- /dev/null
+++ b/abs/core/python_modules/python-py/PKGBUILD
@@ -0,0 +1,57 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+# Contributor: Sebastian Wiesner <lunaryorn googlemail com>
+# Contributor: Igor Ramos Tiburcio <irtigor@yahoo.com.br>
+# Contributor: Wieland Hoffmann <themineo+aur@gmail.com>
+# Contributor: Hervé Cauwelier <herve ¤ oursours.net>
+# Contributor: Felix Kaiser <felix.kaiser@fxkr.net>
+
+pkgbase=python-py
+pkgname=('python2-py')
+pkgver=1.4.20
+pkgrel=3
+pkgdesc="library with cross-python path, ini-parsing, io, code, log facilities"
+arch=('any')
+license=('MIT')
+url="http://pylib.readthedocs.org/en/latest/"
+makedepends=('python2-setuptools')
+checkdepends=('python2-pytest')
+source=("http://pypi.python.org/packages/source/p/py/py-$pkgver.tar.gz")
+
+prepare() {
+ cp -r py-${pkgver}{,-py2}
+}
+
+build() {
+# cd "$srcdir/py-${pkgver}"
+# python setup.py build
+
+ cd "$srcdir/py-${pkgver}-py2"
+ python2 setup.py build
+}
+
+check() {
+# cd "$srcdir/py-${pkgver}"
+# LANG=en_US.utf8 py.test
+
+ cd "$srcdir/py-${pkgver}-py2"
+ LANG=en_US.utf8 py.test2
+}
+
+#package_python-py() {
+# depends=('python')
+
+# cd py-${pkgver}
+# python setup.py install --root="${pkgdir}" --optimize=1
+# install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+#}
+
+package_python2-py() {
+ depends=('python2')
+
+ cd py-${pkgver}-py2
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+sha512sums=('db392bd8d52ac2bf7b4785e18aaf58564596f66f15d355ee6f6e4169f6da7847331096ac7118c758ee5ce3f1865502a45f92ca2c99f411c12ee316760ca2b212')
diff --git a/abs/core/python_modules/python-py/__changelog b/abs/core/python_modules/python-py/__changelog
new file mode 100644
index 0000000..488d3cf
--- /dev/null
+++ b/abs/core/python_modules/python-py/__changelog
@@ -0,0 +1 @@
+PKGBUILD: rm py 3 stuff