summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-30 13:34:44 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-30 13:34:44 (GMT)
commitadcdf962cdd781061806d820a9078c35d6d8a659 (patch)
tree0784a2787cc0b74ddae15f7b5e731310d35aec04 /abs/core
parentb220fce3c46d73b62ea09b8f4ef3db7c40b96532 (diff)
downloadlinhes_pkgbuild-adcdf962cdd781061806d820a9078c35d6d8a659.zip
linhes_pkgbuild-adcdf962cdd781061806d820a9078c35d6d8a659.tar.gz
linhes_pkgbuild-adcdf962cdd781061806d820a9078c35d6d8a659.tar.bz2
python-nose: update to 1.3.1
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/python_modules/python-nose/PKGBUILD42
-rw-r--r--abs/core/python_modules/python-nose/__changelog2
2 files changed, 23 insertions, 21 deletions
diff --git a/abs/core/python_modules/python-nose/PKGBUILD b/abs/core/python_modules/python-nose/PKGBUILD
index 5d36e01..be20823 100644
--- a/abs/core/python_modules/python-nose/PKGBUILD
+++ b/abs/core/python_modules/python-nose/PKGBUILD
@@ -1,44 +1,46 @@
-# $Id: PKGBUILD 144082 2011-12-03 05:50:51Z angvp $
-# Maintainer: Angel Velasquez <angvp@archlinux.org>
+# $Id$
+# Maintainer: Dan McGee <dan@archlinux.org>
+# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
# Contributor: Cilyan Olowen <gaknar@gmail.com>
+
pkgbase=python-nose
-pkgname=('python2-nose' )
-pkgver=1.1.2
-pkgrel=3
+pkgname=('python2-nose' 'python-nose-doc')
+pkgver=1.3.1
+pkgrel=2
pkgdesc="A discovery-based unittest extension"
arch=('any')
-url="http://www.somethingaboutorange.com/mrl/projects/nose/"
-license=('LGPL2')
+url='http://readthedocs.org/docs/nose/'
+license=('LGPL2.1')
+makedepends=('python2' 'python2-setuptools' 'python2-sphinx')
source=("http://pypi.python.org/packages/source/n/nose/nose-${pkgver}.tar.gz")
-makedepends=( 'python2' 'python2-distribute' )
-md5sums=('144f237b615e23f21f6a50b2183aa817')
+md5sums=('672398801ddf5ba745c55c6eed79c5aa')
build() {
cd "$srcdir/nose-$pkgver"
sed -i -e "s:man/man1:share/man/man1:g" setup.py
- cp -R $srcdir/nose-$pkgver $srcdir/nose2-$pkgver
+ cp -R "$srcdir/nose-$pkgver" "$srcdir/nose2-$pkgver"
}
-package_python-nose() {
- depends=('python' 'python-distribute')
- cd "$srcdir/nose-$pkgver"
- python setup.py install --prefix=/usr --root=${pkgdir}
- mv "$pkgdir/usr/bin/nosetests" "$pkgdir/usr/bin/nosetests3"
-}
+#package_python-nose() {
+# depends=('python' 'python-setuptools')
+# cd "$srcdir/nose-$pkgver"
+# python3 setup.py install --prefix=/usr --root="${pkgdir}"
+# mv "$pkgdir/usr/bin/nosetests" "$pkgdir/usr/bin/nosetests3"
+#}
package_python2-nose() {
- depends=('python2' 'python2-distribute')
+ depends=('python2' 'python2-setuptools')
cd "$srcdir/nose2-$pkgver"
- python2 setup.py install --prefix=/usr --root=${pkgdir}
+ python2 setup.py install --prefix=/usr --root="${pkgdir}"
mv "$pkgdir/usr/bin/nosetests" "$pkgdir/usr/bin/nosetests2"
- rm -rf $pkgdir/usr/share
+ rm -rf "$pkgdir/usr/share"
}
package_python-nose-doc(){
pkgdesc="Nose documentation and examples"
cd "$srcdir/nose-$pkgver/doc"
- make html
+ make SPHINXBUILD=sphinx-build22 html
mkdir -p "$pkgdir/usr/share/doc/python-nose"
cp -r .build/html "$pkgdir/usr/share/doc/python-nose"
cp -r ../examples "$pkgdir/usr/share/doc/python-nose"
diff --git a/abs/core/python_modules/python-nose/__changelog b/abs/core/python_modules/python-nose/__changelog
index 0802ff6..488d3cf 100644
--- a/abs/core/python_modules/python-nose/__changelog
+++ b/abs/core/python_modules/python-nose/__changelog
@@ -1 +1 @@
-removed python
+PKGBUILD: rm py 3 stuff