summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-01-16 04:21:49 (GMT)
committerCecil <knoppmyth@gmail.com>2011-01-16 04:21:49 (GMT)
commitcf99ce2de096b4fbf9e4e9cb323aa103183fe467 (patch)
treea57bb803ec77551a0cf7003332e4e7689c33c08f /abs/core
parent576da1bc7af4be77c85c4b09e47a9baee20b9aa7 (diff)
downloadlinhes_pkgbuild-cf99ce2de096b4fbf9e4e9cb323aa103183fe467.zip
linhes_pkgbuild-cf99ce2de096b4fbf9e4e9cb323aa103183fe467.tar.gz
linhes_pkgbuild-cf99ce2de096b4fbf9e4e9cb323aa103183fe467.tar.bz2
feh:bumped
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/feh/PKGBUILD38
1 files changed, 26 insertions, 12 deletions
diff --git a/abs/core/feh/PKGBUILD b/abs/core/feh/PKGBUILD
index ad38f8f..95c377c 100644
--- a/abs/core/feh/PKGBUILD
+++ b/abs/core/feh/PKGBUILD
@@ -1,17 +1,31 @@
+# $Id: PKGBUILD 94545 2010-10-08 08:16:45Z bisson $
+# Maintainer:
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: dorphell <dorphell@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=feh
-pkgver=1.3.4
-pkgrel=4
-pkgdesc="feh is a fast, lightweight image viewer which uses imlib2"
-depends=('libjpeg' 'libpng' 'libxinerama' 'giblib')
-#source=(http://linuxbrit.co.uk/downloads/$pkgname-$pkgver.tar.gz)
-source=(http://ftp.gva.es/mirror/debian/pool/main/f/feh/feh_1.3.4.orig.tar.gz)
-url="http://www.linuxbrit.co.uk/feh/"
-arch=('i686')
+pkgver=1.10
+pkgrel=1
+pkgdesc='Fast, lightweight image viewer which uses imlib2'
+arch=('i686' 'x86_64')
+url='https://derf.homelinux.org/~derf/projects/feh/'
+license=('MIT')
+depends=('libxinerama' 'giblib' 'perl')
+makedepends=('libxt')
+source=("https://derf.homelinux.org/~derf/projects/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+sha1sums=('c42095ed6a7636fe9d1ec90d3994f4a57af84681')
build() {
- cd $startdir/src/$pkgname-$pkgver
- ./configure --prefix=/usr
- make || return 1
- make prefix=$startdir/pkg/usr install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ sed -i -e 's:/usr/local:/usr:g' config.mk
+ make
+}
+
+package(){
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}