summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-09 01:24:25 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-09 01:24:25 (GMT)
commitd1a2086bb8760870aa53c28070874069574d735e (patch)
tree5c1075c2a50b57d35d1e847b404c63f2d8797dde /abs/core
parentb0aa31e7f719efa8c818d0a9c56b35444b27c794 (diff)
downloadlinhes_pkgbuild-d1a2086bb8760870aa53c28070874069574d735e.zip
linhes_pkgbuild-d1a2086bb8760870aa53c28070874069574d735e.tar.gz
linhes_pkgbuild-d1a2086bb8760870aa53c28070874069574d735e.tar.bz2
morethemes: 0.24 include. Needs testing -- especially OSD stuff
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/morethemes/PKGBUILD66
-rw-r--r--abs/core/morethemes/retro-wide_video-ui.xml-filetypes.patch22
2 files changed, 88 insertions, 0 deletions
diff --git a/abs/core/morethemes/PKGBUILD b/abs/core/morethemes/PKGBUILD
new file mode 100644
index 0000000..af8f757
--- /dev/null
+++ b/abs/core/morethemes/PKGBUILD
@@ -0,0 +1,66 @@
+pkgname=morethemes
+pkgver=0.24
+pkgrel=1
+pkgdesc="Additional themes for MythTV"
+url="http://www.mythtv.org"
+license="GPL"
+arch=('any')
+depends=('mythtv')
+groups=('mythtv-extras')
+source=(#'ftp://ftp.knoppmyth.net/R6/sources/morethemes-0.23.tar.bz2'
+ 'ftp://miroku.no-ip.com/blue-abstract-wide.2010.09.16.tar.bz2'
+ 'http://elkin.de/mythtv/2010.09.08-blootube-ng.tar.bz2'
+ 'http://elkin.de/mythtv/2010.11.04-Willi.tar.lzma'
+ 'http://elkin.de/mythtv/2010.03.13-bando-blue.tar.bz2'
+ 'http://www.thepetersclan.com/files/TintedGlass-1.18.tbz2'
+ 'http://www.thepetersclan.com/files/Mod-Gray-OSD.tar.bz2'
+ 'http://www.thepetersclan.com/files/Bluebar-Hires-OSD.tar.bz2'
+ 'http://www.thepetersclan.com/files/BlueCurves-OSD.tar.bz2'
+ 'http://www.thepetersclan.com/files/SimplyBlue-OSD.tbz2'
+ 'http://www.thepetersclan.com/files/BlueCurves2-OSD.tbz2'
+ 'http://www.thepetersclan.com/files/BlueCurves-2.1-OSD.tbz2'
+ 'http://www.mythtv.org/themes/LCARS.tar.gz'
+ 'http://www.mythtv.org/themes/TransBlue.tar.gz'
+ 'http://www.westnet.com/~chris/Mythtv/Retro-wide.tar.gz'
+ 'retro-wide_video-ui.xml-filetypes.patch'
+ 'http://capnbry.net/~bmayland/fi/pvr150/SimpleGray-OSD-0.4.tar.bz2'
+ 'http://www.jobs-khakis-chicks.com/MythTV/IsthmusBlue-OSD.tar.gz'
+ 'http://static.castlesblog.com/public/Glass-OSD-V1.3.zip'
+ 'http://static.castlesblog.com/public/Minimal-OSD-V1.1.zip')
+
+build() {
+ cd ${srcdir}
+ mkdir -p ${pkgdir}/usr/share/mythtv/themes
+
+ msg "Copying files..."
+ for d in `ls -d */`
+ do
+ cp -a "${d}" ${pkgdir}/usr/share/mythtv/themes
+ done
+
+ # Housekeeping
+ rm -fr "${pkgdir}/usr/share/mythtv/themes/__MACOSX" || return 1
+ # Little fix
+ cd ${pkgdir}/usr/share/mythtv/themes/Retro-wide || return 1
+ patch -p0 <${srcdir}/retro-wide_video-ui.xml-filetypes.patch || return 1
+}
+
+md5sums=('878605505599a0f49c44f3df9affe10f'
+ '7c2a2b238b7d44e52b7a8a0361d395aa'
+ '2890f3b991db805a88a48eb6c7048f91'
+ 'c6d90fb469bc30a94e32f76c82122dd3'
+ '80d250bf87c8f72ee238a91c854c0a11'
+ 'c973d0779967034f7a5bc0043574d6f9'
+ 'fb32ddd900e54cff62a62a21025b2585'
+ '79247cf87bbee10363bb214325b7f671'
+ '67c501b80afdefeca623261634dafd9c'
+ '7b2f2eca37f2d9598b00bce85a193bae'
+ '9793dc85a486e1ad9d0c0b6684efd245'
+ 'a36bb7b2597a44128401b1aba9106122'
+ '21d6f967631e45b7039b965a63755282'
+ 'bfc56ffe1c872989f7a1cb7ae20aea49'
+ 'e05bb3d77a11f97a1d547b2f5bc1ddf7'
+ '09dd8679b56794f9850a2382b4e1ea62'
+ 'b6c187b233778abacce102fe609d4e09'
+ 'f8d4fd90f1e45512ea5237de59d5090d'
+ '5646e1df6f593f7116cbdec656146266')
diff --git a/abs/core/morethemes/retro-wide_video-ui.xml-filetypes.patch b/abs/core/morethemes/retro-wide_video-ui.xml-filetypes.patch
new file mode 100644
index 0000000..c98487f
--- /dev/null
+++ b/abs/core/morethemes/retro-wide_video-ui.xml-filetypes.patch
@@ -0,0 +1,22 @@
+--- video-ui.xml.orig 2010-07-04 06:21:18.000000000 +0000
++++ video-ui.xml 2010-07-04 06:22:22.000000000 +0000
+@@ -967,14 +967,17 @@
+
+ <button name="done_button" from="basebutton">
+ <position>700,550</position>
++ <value>Done</value>
+ </button>
+
+ <button name="new_button" from="basebutton">
+- <position>600,550</position>
++ <position>400,550</position>
++ <value>New</value>
+ </button>
+
+ <button name="delete_button" from="basebutton">
+- <position>0,550</position>
++ <position>100,550</position>
++ <value>Delete</value>
+ </button>
+ </window>
+