summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-05 18:18:39 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-05 18:18:39 (GMT)
commitde6718e325ed5fdcb2b15cb567732321ecb14790 (patch)
tree38be8b17b5a48debab24d58543312e29679e4ab0 /abs/core
parentfc539f5d4dfd5c641545ba0442431219f63bcbe3 (diff)
downloadlinhes_pkgbuild-de6718e325ed5fdcb2b15cb567732321ecb14790.zip
linhes_pkgbuild-de6718e325ed5fdcb2b15cb567732321ecb14790.tar.gz
linhes_pkgbuild-de6718e325ed5fdcb2b15cb567732321ecb14790.tar.bz2
initscripts: update to 2014.03.1
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/initscripts/PKGBUILD38
-rw-r--r--abs/core/initscripts/__changelog6
-rw-r--r--abs/core/initscripts/initscripts.install29
-rw-r--r--abs/core/initscripts/rc.shutdown.patch9
-rw-r--r--abs/core/initscripts/split-hwclock-calls.diff21
5 files changed, 54 insertions, 49 deletions
diff --git a/abs/core/initscripts/PKGBUILD b/abs/core/initscripts/PKGBUILD
index 14fa502..370c5f4 100644
--- a/abs/core/initscripts/PKGBUILD
+++ b/abs/core/initscripts/PKGBUILD
@@ -1,33 +1,41 @@
-# $Id: PKGBUILD 168542 2012-10-13 09:29:55Z thomas $
-# Maintainer: Tom Gundersen <teg@jklm.no>
+# Maintainer: Alexey D. <lq07829icatm@rambler.ru>
+# Contributor: Tom Gundersen <teg@jklm.no>
# Contributor: Thomas Bächler <thomas@archlinux.org>
# Contributor: Aaron Griffin <aaron@archlinux.org>
pkgname=initscripts
-pkgver=2012.10.1
-pkgrel=2
-pkgdesc="System initialization/bootup scripts"
+pkgver=2014.03.1
+pkgrel=1
+pkgdesc="Maintained fork of system initialization/bootup scripts"
arch=('any')
-url="http://www.archlinux.org"
+url="https://bitbucket.org/TZ86/initscripts-fork/overview"
license=('GPL2')
provides=('initscripts-systemd')
conflicts=('initscripts-systemd')
replaces=('initscripts-systemd')
backup=(etc/inittab etc/rc.conf etc/rc.local etc/rc.local.shutdown)
-depends=('glibc' 'bash' 'coreutils' 'systemd-tools' 'iproute2' 'ncurses' 'findutils' 'sysvinit-tools')
+depends=('glibc' 'bash' 'coreutils' 'iproute2' 'ncurses' 'findutils' 'procps-ng' 'kbd')
optdepends=('dhcpcd: DHCP network configuration'
- 'bridge-utils: Legacy network bridging support'
- 'net-tools: Legacy network support'
- 'wireless_tools: Legacy wireless networking'
- 'sysvinit: Legacy init support')
+ 'bridge-utils: Network bridging support'
+ 'net-tools: Network support'
+ 'wireless_tools: Wireless networking'
+ 'systemd: new crypttab format support'
+ 'sysctl-default-conf: additional tweaks for kernel parameters')
makedepends=(asciidoc)
install=initscripts.install
-source=("ftp://ftp.archlinux.org/other/initscripts/${pkgname}-${pkgver}.tar.xz")
+source=(https://bitbucket.org/TZ86/$pkgname-fork/get/$pkgver.tar.bz2)
+md5sums=('f13aab36792429344ff685b64206722d')
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd TZ86-$pkgname-*
make DESTDIR=${pkgdir} install
- mv $pkgdir/usr/sbin $pkgdir/usr/bin
+
+ #comment out some rc.conf options
+ sed -i 's/NETWORK_PERSIST=/#NETWORK_PERSIST=/g' ${pkgdir}/etc/rc.conf
+ sed -i 's/DAEMONS=/#DAEMONS=/g' ${pkgdir}/etc/rc.conf
+ #don't use bootlogd
+ sed -i 's/bootlogd /#bootlogd /g' ${pkgdir}/etc/rc.sysinit
}
-md5sums=('a4a747e73819b81f2218cf5b9bd53703')
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core/initscripts/__changelog b/abs/core/initscripts/__changelog
new file mode 100644
index 0000000..f6b268d
--- /dev/null
+++ b/abs/core/initscripts/__changelog
@@ -0,0 +1,6 @@
+- from initscripts-fork AUR https://aur.archlinux.org/packages/initscripts-fork/
+- PKGBUILD: changed pkgname to initscripts
+- PKGBUILD: removed initscripts from provides, conflicts, replaces
+- PKGBUILD: remove dep sysvinit
+- PKGBUILD: comment out of rc.conf NETWORK_PERSIST= and DAEMONS=
+- PKGBUILD: comment out of rc.sysinit starting bootlogd
diff --git a/abs/core/initscripts/initscripts.install b/abs/core/initscripts/initscripts.install
index 03519cb..2e7b24f 100644
--- a/abs/core/initscripts/initscripts.install
+++ b/abs/core/initscripts/initscripts.install
@@ -1,3 +1,11 @@
+show_link() {
+ echo "----"
+ echo "> You can find all missed scripts and config files on https://bitbucket.org/TZ86/arch-rcscripts"
+ echo "----"
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
post_upgrade() {
if [ "$(vercmp $2 2011.06.1)" -lt 0 ]; then
echo "Blacklisting of modules is no longer supported in rc.conf,"
@@ -18,9 +26,22 @@ post_upgrade() {
echo "> shutdown, respectively. Refer to arch-modules-load(8) and arch-daemons(8)."
echo "----"
fi
- if [ "$(vercmp $2 2012.10.1)" -lt 0 ]; then
- echo "----"
- echo "> systemd no longer reads MODULES from rc.conf."
- echo "----"
+ if [ "$(vercmp $2 2013.10.1)" -lt 0 ]; then
+ show_link
fi
}
+
+post_install() {
+ echo "----"
+ echo "> All localization parameters, network and kernel modules settings has been"
+ echo "> moved to rc.conf. Systemd configs (such as vconsole.conf) is still supports"
+ echo "> but is not recommended."
+ echo
+ echo "> Please note that now rc.conf overrides systemd configs. If you want keep"
+ echo "> using systemd configs, just leave the corresponding parameter in rc.conf"
+ echo "> commented out."
+ echo "----"
+
+ show_link
+}
+
diff --git a/abs/core/initscripts/rc.shutdown.patch b/abs/core/initscripts/rc.shutdown.patch
deleted file mode 100644
index 407349e..0000000
--- a/abs/core/initscripts/rc.shutdown.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-+#unmount network filesystems for runit
-+INIT=`ps -p1 -o comm=`
-+if [ x$INIT = xrunit ]
-+then
-+ if [ -e /var/services/netfs ]
-+ then
-+ /etc/rc.d/netfs stop
-+ fi
-+fi
diff --git a/abs/core/initscripts/split-hwclock-calls.diff b/abs/core/initscripts/split-hwclock-calls.diff
deleted file mode 100644
index c0a6a4f..0000000
--- a/abs/core/initscripts/split-hwclock-calls.diff
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/rc.sysinit b/rc.sysinit
-index eb49e2b..8f9727b 100755
---- a/rc.sysinit
-+++ b/rc.sysinit
-@@ -34,7 +34,6 @@ bootlogd -p /run/bootlogd.pid
-
- run_hook sysinit_start
-
--HWCLOCK_PARAMS="--systz"
- case $HARDWARECLOCK in
- "") ;;
- UTC) HWCLOCK_PARAMS+=" --utc --noadjfile";;
-@@ -54,7 +53,7 @@ if [[ $HWCLOCK_PARAMS ]]; then
-
- [[ $TIMEZONE ]] && export TZ=$TIMEZONE
-
-- hwclock $HWCLOCK_PARAMS && stat_done || stat_fail
-+ { hwclock $HWCLOCK_PARAMS && hwclock --systz; } && stat_done || stat_fail
-
- unset TZ
- fi