summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-16 16:37:16 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-16 16:37:16 (GMT)
commiteb65e92be2f22c5b0047bbd4e36460e7628f3c08 (patch)
tree077387215c90d551cfe62f0c8c17c5919e37e2fc /abs/core
parent041d38fb3be61ecc369a0ecea30b8f8861877b7e (diff)
downloadlinhes_pkgbuild-eb65e92be2f22c5b0047bbd4e36460e7628f3c08.zip
linhes_pkgbuild-eb65e92be2f22c5b0047bbd4e36460e7628f3c08.tar.gz
linhes_pkgbuild-eb65e92be2f22c5b0047bbd4e36460e7628f3c08.tar.bz2
dbus-core: remove; included in dbus
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/dbus-core/PKGBUILD54
-rw-r--r--abs/core/dbus-core/dbus51
-rw-r--r--abs/core/dbus-core/dbus.install23
3 files changed, 0 insertions, 128 deletions
diff --git a/abs/core/dbus-core/PKGBUILD b/abs/core/dbus-core/PKGBUILD
deleted file mode 100644
index afca05e..0000000
--- a/abs/core/dbus-core/PKGBUILD
+++ /dev/null
@@ -1,54 +0,0 @@
-# $Id: PKGBUILD 163992 2012-07-23 14:58:38Z andyrtr $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
-# Contributor: Link Dupont <link@subpop.net>
-#
-pkgname=dbus-core
-pkgver=1.6.4
-pkgrel=1
-pkgdesc="Freedesktop.org message bus system"
-url="http://www.freedesktop.org/Software/dbus"
-arch=(i686 x86_64)
-license=('GPL' 'custom')
-depends=('expat' 'coreutils' 'filesystem' 'libsystemd' 'shadow' 'systemd-tools') # shadow for install scriptlet FS#29341
-makedepends=('libx11')
-options=(!libtool)
-install=dbus.install
-source=(http://dbus.freedesktop.org/releases/dbus/dbus-$pkgver.tar.gz{,.asc}
- dbus)
-md5sums=('5ec43dc4554cba638917317b2b4f7640'
- '3d4482ee39b49da334441c76f83bf1cb'
- 'f0364f3f5dc5f653bb05d39aa36e3264')
-
-build() {
- cd dbus-$pkgver
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --libexecdir=/usr/lib/dbus-1.0 --with-dbus-user=81 \
- --with-system-pid-file=/run/dbus/pid \
- --with-system-socket=/run/dbus/system_bus_socket \
- --with-console-auth-dir=/run/console/ \
- --enable-inotify --disable-dnotify \
- --disable-verbose-mode --disable-static \
- --disable-tests --disable-asserts \
- --with-systemdsystemunitdir=/usr/lib/systemd/system \
- --enable-systemd
- make
-}
-
-package(){
- cd dbus-$pkgver
- make DESTDIR="$pkgdir" install
-
- rm -f "$pkgdir/usr/bin/dbus-launch"
- rm -f "$pkgdir/usr/share/man/man1/dbus-launch.1"
- rm -rf "$pkgdir/var/run"
-
- install -m755 -d "$pkgdir/etc/rc.d"
- install -m755 ../dbus "$pkgdir/etc/rc.d/"
-
- #Fix configuration file
- sed -i -e 's|<user>81</user>|<user>dbus</user>|' "$pkgdir/etc/dbus-1/system.conf"
-
- install -dm755 "$pkgdir/usr/share/licenses/dbus-core"
- install -m644 COPYING "$pkgdir/usr/share/licenses/dbus-core/"
-}
-
diff --git a/abs/core/dbus-core/dbus b/abs/core/dbus-core/dbus
deleted file mode 100644
index bf532a2..0000000
--- a/abs/core/dbus-core/dbus
+++ /dev/null
@@ -1,51 +0,0 @@
-#!/bin/bash
-
-# general config
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-case $1 in
- start)
- stat_busy "Starting D-BUS system messagebus"
- if [[ ! -d /run/dbus ]] ; then
- install -m755 -g 81 -o 81 -d /run/dbus
- fi
-
- if ! dbus-daemon --system; then
- stat_fail
- else
- add_daemon dbus
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping D-BUS system messagebus"
- if ! { [[ -f /run/dbus/pid ]] && kill $(</run/dbus/pid); }; then
- stat_fail
- else
- rm -f /run/dbus/pid
- rm_daemon dbus
- stat_done
- fi
- ;;
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
- reload)
- stat_busy "Reloading D-BUS configuration"
- if ! { [[ -f /run/dbus/pid ]] && dbus-send \
- --system --type=method_call \
- --dest=org.freedesktop.DBus \
- / org.freedesktop.DBus.ReloadConfig; }; then
- stat_fail
- else
- stat_done
- fi
- ;;
- *)
- echo "usage: $0 {start|stop|restart|reload}"
- ;;
-esac
-exit 0
diff --git a/abs/core/dbus-core/dbus.install b/abs/core/dbus-core/dbus.install
deleted file mode 100644
index f1ffd61..0000000
--- a/abs/core/dbus-core/dbus.install
+++ /dev/null
@@ -1,23 +0,0 @@
-post_install() {
- getent group dbus >/dev/null || groupadd -g 81 dbus
- getent passwd dbus >/dev/null || useradd -c 'System message bus' -u 81 -g dbus -d '/' -s /bin/false dbus
- passwd -l dbus &>/dev/null
-}
-
-post_upgrade() {
- post_install
-
- # Make sure new rc script can shutdown running dbus
- if [ -f run/dbus.pid -a -d run/dbus ]; then
- mv run/dbus.pid run/dbus/pid
- fi
-}
-
-post_remove() {
- if getent passwd dbus >/dev/null; then
- userdel dbus
- fi
- if getent group dbus >/dev/null; then
- groupdel dbus
- fi
-}