summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-11 14:11:59 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-11 14:11:59 (GMT)
commitf99b659f10f2d6016b115da7ae6d8af4ff75d585 (patch)
treee4891f52e72b210f160ada7421fd34bc2b57e67e /abs/core
parenta70c8f95c4f0cc69f3f358482c628eccf0aaf198 (diff)
downloadlinhes_pkgbuild-f99b659f10f2d6016b115da7ae6d8af4ff75d585.zip
linhes_pkgbuild-f99b659f10f2d6016b115da7ae6d8af4ff75d585.tar.gz
linhes_pkgbuild-f99b659f10f2d6016b115da7ae6d8af4ff75d585.tar.bz2
LinHES-system: idle.py: add to check if mythfrontends are in menus and if not system busy.
Diffstat (limited to 'abs/core')
-rwxr-xr-xabs/core/LinHES-system/PKGBUILD4
-rwxr-xr-xabs/core/LinHES-system/idle.py12
2 files changed, 11 insertions, 5 deletions
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index cc3ec38..d151b48 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-system
pkgver=8.1
-pkgrel=22
+pkgrel=23
arch=('i686' 'x86_64')
install=system.install
pkgdesc="Everything that makes LinHES an automated system"
@@ -119,7 +119,7 @@ md5sums=('a10cb96850951ae835c46f41f92463b2'
'8b0298f70f97cc1dc2a58b9a73c64bd3'
'911b0fbc8d9178dac1a193346c9decaf'
'34fc1f58ad1eabf4eff4979d420760c0'
- '1118e7982ba77cb5be9b2391b7cdfd38'
+ 'b08a9c9aa1215e9aa3aa7d2e654e72e5'
'a94fe6d980f4b810f2e2ae5352084b39'
'384956b4fd9bf40907856bab0e67b169'
'f4ce577e2ab1b6dbf9def46a8ab86e2d'
diff --git a/abs/core/LinHES-system/idle.py b/abs/core/LinHES-system/idle.py
index 40bbb16..16dc873 100755
--- a/abs/core/LinHES-system/idle.py
+++ b/abs/core/LinHES-system/idle.py
@@ -207,13 +207,18 @@ def mythfe_check(cmdargs,cursor,mythDB):
return False
else:
msg(cmdargs," %s's mythfrontend is NOT playing." %i)
+ if '.xml' in location or 'mainmenu' in location:
+ msg(cmdargs," %s's mythfrontend is in MENUS." %i)
+ else:
+ msg(cmdargs," %s's mythfrontend is NOT in menus." %i)
+ return False
except:
msg(cmdargs," Could not connect to %s's mythfrontend." %i)
if ( cmdargs.runningfe ):
- msg(cmdargs," No mythfrontends are running or playing.")
+ msg(cmdargs," mythfrontends are not running or playing or are in menus.")
else:
- msg(cmdargs," No mythfrontends are playing.")
+ msg(cmdargs," mythfrontends are not playing or are in menus.")
return True
@@ -235,8 +240,9 @@ def usage():
- mythtv-setup is running return busy
- There are upcoming recordings return busy
checks the next 15 minutes. -t TIME changes time
- - mythfrontends playing back a recording or video
- (option -r) mythfrontends running
+ - mythfrontends playing back a recording or video
+ - mythfrontends not in menus
idle.py stops checking and returns false (busy) when the first busy is found.
'''