summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/abs/abs.install
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-05 14:38:10 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-05 14:38:10 (GMT)
commitee33ddf6f3657ff6384de9c6e517511f0427ffc7 (patch)
treec02a8afa5bdd1099494f7d436a58dec4bf086b12 /abs/extra-testing/abs/abs.install
parentd6049e8a38b8babf070b6f2183c336334ed97fd9 (diff)
downloadlinhes_pkgbuild-ee33ddf6f3657ff6384de9c6e517511f0427ffc7.zip
linhes_pkgbuild-ee33ddf6f3657ff6384de9c6e517511f0427ffc7.tar.gz
linhes_pkgbuild-ee33ddf6f3657ff6384de9c6e517511f0427ffc7.tar.bz2
Goodbye chroot-devel.
All things chroot-devel have been moved and split between core and extra
Diffstat (limited to 'abs/extra-testing/abs/abs.install')
-rw-r--r--abs/extra-testing/abs/abs.install15
1 files changed, 15 insertions, 0 deletions
diff --git a/abs/extra-testing/abs/abs.install b/abs/extra-testing/abs/abs.install
new file mode 100644
index 0000000..1b19b4a
--- /dev/null
+++ b/abs/extra-testing/abs/abs.install
@@ -0,0 +1,15 @@
+## arg 1: the new package version
+## arg 2: the old package version
+pre_upgrade() {
+ if [ "$(vercmp $2 2.0-1)" -lt 0 ]; then
+ echo "==> ABS now uses rsync, instead of cvsup, to synchronize your tree."
+ echo "==> Please note the new configuration in /etc/abs.conf"
+ fi
+
+ if [ "$(vercmp $2 2.0-4)" -lt 0 ]; then
+ echo "==> Warning: abs clears out the contents of /var/abs when syncing."
+ echo "==> Keep all local PKGBUILDs in /var/abs/local, or they will disappear"
+ fi
+}
+
+# vim:set ts=2 sw=2 et: