summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/apcupsd/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-23 00:55:28 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-23 00:55:28 (GMT)
commit2fc15d3074871bd939534a6b681779e4cb42aaec (patch)
treeb57b1a793eb4ba6dcea70cea2d725d176f674760 /abs/extra-testing/apcupsd/PKGBUILD
parent18a13d7b7ff77cec786897a3d00114f07a1c1a05 (diff)
downloadlinhes_pkgbuild-2fc15d3074871bd939534a6b681779e4cb42aaec.zip
linhes_pkgbuild-2fc15d3074871bd939534a6b681779e4cb42aaec.tar.gz
linhes_pkgbuild-2fc15d3074871bd939534a6b681779e4cb42aaec.tar.bz2
Initial inclusion of apcupsd.
Diffstat (limited to 'abs/extra-testing/apcupsd/PKGBUILD')
-rw-r--r--abs/extra-testing/apcupsd/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/extra-testing/apcupsd/PKGBUILD b/abs/extra-testing/apcupsd/PKGBUILD
new file mode 100644
index 0000000..7f20cab
--- /dev/null
+++ b/abs/extra-testing/apcupsd/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD,v 1.17 2009/01/19 10:34:32 sergej Exp $
+# Maintainer: Sergej Pupykin <sergej@aur.archlinux.org>
+# Maintainer: Todd Musall <tmusall@comcast.net>
+
+pkgname=apcupsd
+pkgver=3.14.5
+pkgrel=1
+pkgdesc="Apcupsd can be used for power mangement and controlling most of APC's UPS models on Unix and Windows machines."
+arch=(i686 x86_64)
+url="http://www.apcupsd.org"
+license=('GPL')
+depends=('gcc-libs' 'gd' 'gconf')
+makedepends=('pkgconfig')
+backup=(etc/apcupsd/apcupsd.conf etc/apcupsd/hosts.conf \
+ etc/apcupsd/multimon.conf)
+source=(http://switch.dl.sf.net/sourceforge/apcupsd/$pkgname-$pkgver.tar.gz \
+ apcupsd)
+md5sums=('4ac73ec91d8ab56f3fac894e172567c4'
+ '5eae3c4d921eeb81798a0250fe3dd111')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr --enable-cgi --enable-usb --enable-net \
+ --with-upstype=usb --with-upscable=usb \
+ --with-serial-dev=/dev/usb/hid/hiddev[0-9] \
+ --enable-pthreads --enable-gapcmon
+ make || return 1
+ make DESTDIR=$startdir/pkg install || return 1
+ install -D -m755 ../apcupsd $startdir/pkg/etc/rc.d/apcupsd && \
+ chmod 755 $startdir/pkg/sbin/*
+}