summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/apcupsd/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-23 12:59:24 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-23 12:59:24 (GMT)
commit4702175bc8bf5f1af5c16d6ddd02140d017b8e02 (patch)
tree46ff7be00d803dcf0048e5faf3dfc76ff5718331 /abs/extra-testing/apcupsd/PKGBUILD
parent8def6e31ab03a963b14b30c4ed09dccc47ad09d1 (diff)
downloadlinhes_pkgbuild-4702175bc8bf5f1af5c16d6ddd02140d017b8e02.zip
linhes_pkgbuild-4702175bc8bf5f1af5c16d6ddd02140d017b8e02.tar.gz
linhes_pkgbuild-4702175bc8bf5f1af5c16d6ddd02140d017b8e02.tar.bz2
Updated apcupsd to include run for runit and gave it a stattime of 5 mins for RRD logging.
Diffstat (limited to 'abs/extra-testing/apcupsd/PKGBUILD')
-rw-r--r--abs/extra-testing/apcupsd/PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/abs/extra-testing/apcupsd/PKGBUILD b/abs/extra-testing/apcupsd/PKGBUILD
index 7f20cab..9f66f5d 100644
--- a/abs/extra-testing/apcupsd/PKGBUILD
+++ b/abs/extra-testing/apcupsd/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=apcupsd
pkgver=3.14.5
-pkgrel=1
+pkgrel=2
pkgdesc="Apcupsd can be used for power mangement and controlling most of APC's UPS models on Unix and Windows machines."
arch=(i686 x86_64)
url="http://www.apcupsd.org"
@@ -14,9 +14,13 @@ makedepends=('pkgconfig')
backup=(etc/apcupsd/apcupsd.conf etc/apcupsd/hosts.conf \
etc/apcupsd/multimon.conf)
source=(http://switch.dl.sf.net/sourceforge/apcupsd/$pkgname-$pkgver.tar.gz \
- apcupsd)
+ apcupsd
+ apcupsd.conf
+ run)
md5sums=('4ac73ec91d8ab56f3fac894e172567c4'
- '5eae3c4d921eeb81798a0250fe3dd111')
+ '5eae3c4d921eeb81798a0250fe3dd111'
+ '2f533aec32c9445510bb2127b453b175'
+ 'd4b8c755ecd30f57810f71a6d6435dd3')
build() {
cd $startdir/src/$pkgname-$pkgver
@@ -28,4 +32,7 @@ build() {
make DESTDIR=$startdir/pkg install || return 1
install -D -m755 ../apcupsd $startdir/pkg/etc/rc.d/apcupsd && \
chmod 755 $startdir/pkg/sbin/*
+ cp ../apcupsd.conf $startdir/pkg/etc/apcupsd/
+ mkdir -p $startdir/pkg/etc/sv/apcupsd/supervise
+ install -D -m755 ../run $startdir/pkg/etc/sv/apcupsd
}