summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/autofs/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/extra-testing/autofs/PKGBUILD
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/extra-testing/autofs/PKGBUILD')
-rwxr-xr-xabs/extra-testing/autofs/PKGBUILD50
1 files changed, 0 insertions, 50 deletions
diff --git a/abs/extra-testing/autofs/PKGBUILD b/abs/extra-testing/autofs/PKGBUILD
deleted file mode 100755
index ae04100..0000000
--- a/abs/extra-testing/autofs/PKGBUILD
+++ /dev/null
@@ -1,50 +0,0 @@
-# $Id: PKGBUILD 75323 2010-04-01 10:16:24Z allan $
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
-# Contributor: Dale Blount <dale@archlinux.org>
-# Contributor: Manolis Tzanidakis
-
-pkgname=autofs
-pkgver=5.0.5
-pkgrel=3
-pkgdesc="A kernel-based automounter for Linux"
-arch=('i686' 'x86_64')
-url="http://wiki.autofs.net/FrontPage"
-license=('GPL2')
-depends=('libldap' 'libxml2' 'heimdal')
-backup=(etc/autofs/auto.master etc/autofs/auto.misc etc/conf.d/autofs)
-install=${pkgname}.install
-source=("http://www.kernel.org/pub/linux/daemons/${pkgname}/v5/${pkgname}-${pkgver}.tar.bz2"
- 'autofs' 'autofs.conf.d' 'auto.master' 'auto.misc'
- 'heimdal.patch')
-md5sums=('a1d262cb6ebef0c2dd0fe22232fb3d5a'
- 'e307bf6d2638e46eeb916cf42fe029b2'
- '47f597c870410055e0fdb66103daf928'
- 'a6cefb591e77b31b79dbb7243646c96b'
- 'd8a15ec9186c5c0b36e5cea1e2739e8a'
- 'efd46b6406b940cb48f7c6197790fb8e')
-
-build() {
- export MAKEFLAGS="-j1"
- cd ${srcdir}/${pkgname}-${pkgver}
-
- sed -i "s:SUBDIRS = lib daemon modules man samples:SUBDIRS = lib daemon modules man:" Makefile.rules
- patch -Np1 -i ${srcdir}/heimdal.patch
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc/autofs \
- --with-mapdir=/etc/autofs \
- --without-hesiod
- make || return 1
-
- sed -i "s:/etc:/etc/autofs:g" man/auto.master.5
-}
-
-package(){
- cd ${srcdir}/${pkgname}-${pkgver}
- make INSTALLROOT=${pkgdir} install
-
- install -Dm644 ${srcdir}/auto.master ${pkgdir}/etc/autofs/auto.master || return 1
- install -Dm644 ${srcdir}/auto.misc ${pkgdir}/etc/autofs/auto.misc || return 1
- install -Dm755 ${srcdir}/autofs ${pkgdir}/etc/rc.d/autofs || return 1
- install -Dm644 ${srcdir}/autofs.conf.d ${pkgdir}/etc/conf.d/autofs || return 1
-}