summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/autofs/run
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verison.net>2010-06-28 20:22:05 (GMT)
committerMichael Hanson <hansonorders@verison.net>2010-06-28 20:22:05 (GMT)
commit50393bfc3f7d530ea28bb3a5b22c4ee5704d7f16 (patch)
tree5926ca994806f944b2f4ba7a1a343898b5fcecbc /abs/extra-testing/autofs/run
parentd6700409fe40996d8185e25c7c375a1a8c250864 (diff)
parent25d4840e95d5e669f9e09ce23615eaa5051a247e (diff)
downloadlinhes_pkgbuild-50393bfc3f7d530ea28bb3a5b22c4ee5704d7f16.zip
linhes_pkgbuild-50393bfc3f7d530ea28bb3a5b22c4ee5704d7f16.tar.gz
linhes_pkgbuild-50393bfc3f7d530ea28bb3a5b22c4ee5704d7f16.tar.bz2
Merge branch 'master' of mihanson@knoppmyth.net:LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/autofs/run')
-rwxr-xr-xabs/extra-testing/autofs/run11
1 files changed, 10 insertions, 1 deletions
diff --git a/abs/extra-testing/autofs/run b/abs/extra-testing/autofs/run
index b35a4ea..7d146fc 100755
--- a/abs/extra-testing/autofs/run
+++ b/abs/extra-testing/autofs/run
@@ -2,4 +2,13 @@
exec 2>&1
set -e # barf if modprobe fails
/sbin/modprobe autofs4
-exec /etc/rc.d/autofs start
+#exec /etc/rc.d/autofs start
+
+# source application-specific settings
+[ -f /etc/conf.d/autofs ] && . /etc/conf.d/autofs
+
+if [ ! -z "$TIMEOUT" ]; then
+ daemonoptions="--timeout=$TIMEOUT $daemonoptions"
+fi
+
+exec /usr/sbin/automount -f $daemonoptions