summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/bash-completion/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-03-18 21:26:14 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-03-18 21:26:14 (GMT)
commit316d04462eeadfdec54e513357a7ff7a97597a1c (patch)
tree9ebb068eb42d425102b8a7464dd6bdc47805e21c /abs/extra-testing/bash-completion/PKGBUILD
parenta0fec6df1576432d91163c6a8e13c9ee251ddbf0 (diff)
downloadlinhes_pkgbuild-316d04462eeadfdec54e513357a7ff7a97597a1c.zip
linhes_pkgbuild-316d04462eeadfdec54e513357a7ff7a97597a1c.tar.gz
linhes_pkgbuild-316d04462eeadfdec54e513357a7ff7a97597a1c.tar.bz2
bash-completion: initial import
closes 567
Diffstat (limited to 'abs/extra-testing/bash-completion/PKGBUILD')
-rw-r--r--abs/extra-testing/bash-completion/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/extra-testing/bash-completion/PKGBUILD b/abs/extra-testing/bash-completion/PKGBUILD
new file mode 100644
index 0000000..a60a49a
--- /dev/null
+++ b/abs/extra-testing/bash-completion/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 67318 2010-02-06 09:38:55Z eric $
+# Maintainer: Aaron Griffin <aaron@archlinux.org>
+# Contributor: Aurelien Foret <orelien@chez.com>
+# Contributor: Evangelos Foutras <foutrelis@gmail.com>
+
+pkgname=bash-completion
+pkgver=1.1
+pkgrel=3
+pkgdesc="Programmable completion for the bash shell"
+arch=(any)
+url="http://bash-completion.alioth.debian.org/"
+license=('GPL')
+depends=('bash')
+source=(http://bash-completion.alioth.debian.org/files/$pkgname-$pkgver.tar.gz cowsay.bashcomp)
+md5sums=('593d3edcf287b9e9d735049bd4d3f229' 'e9766bdc391caf825cb24e704422987e')
+sha1sums=('0e666ebda3d577571ab62bcecc16e1024922cd18' 'a8620aa1029d46bae92be8a6ea0eb62d737545ef')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # fixes for archlinux
+ sed -i 's#/sbin/lsmod#/bin/lsmod#' bash_completion || return 1
+
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ install -D -m644 "$srcdir/cowsay.bashcomp" "$pkgdir/etc/bash_completion.d/cowsay"
+
+ # apache2ctl doesn't work, even when renamed to apachectl (and sed'd)
+ rm "$pkgdir/etc/bash_completion.d/apache2ctl"
+ # munin-node doesn't work, even i've updated munin to 1.4.0
+ rm "$pkgdir/etc/bash_completion.d/munin-node"
+}
+# vim:set ts=2 sw=2 et: