summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/bluez/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verison.net>2010-04-01 23:28:58 (GMT)
committerMichael Hanson <hansonorders@verison.net>2010-04-01 23:28:58 (GMT)
commit71fef603911d15fd30b1033e565aecb01c4a1c11 (patch)
treeb78b30f64f69f6361f4385a2df8560882b328c93 /abs/extra-testing/bluez/PKGBUILD
parente529a6ff6ddfdacdb63591fbee673a970f531d05 (diff)
downloadlinhes_pkgbuild-71fef603911d15fd30b1033e565aecb01c4a1c11.zip
linhes_pkgbuild-71fef603911d15fd30b1033e565aecb01c4a1c11.tar.gz
linhes_pkgbuild-71fef603911d15fd30b1033e565aecb01c4a1c11.tar.bz2
bluez: Add runit support. Needs testing.
Ref #676
Diffstat (limited to 'abs/extra-testing/bluez/PKGBUILD')
-rw-r--r--abs/extra-testing/bluez/PKGBUILD26
1 files changed, 20 insertions, 6 deletions
diff --git a/abs/extra-testing/bluez/PKGBUILD b/abs/extra-testing/bluez/PKGBUILD
index 46af613..f39539a 100644
--- a/abs/extra-testing/bluez/PKGBUILD
+++ b/abs/extra-testing/bluez/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Geoffroy Carrier <geoffroy@archlinux.org>
pkgname=bluez
pkgver=4.62
-pkgrel=1
+pkgrel=2
pkgdesc="Libraries and tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
arch=('i686' 'x86_64')
@@ -12,11 +12,13 @@ optdepends=('gstreamer0.10-base' 'alsa-lib' 'libusb')
conflicts=('bluez-libs' 'bluez-utils')
provides=('bluez-libs' 'bluez-utils')
replaces=('bluez-libs' 'bluez-utils')
+install='bluez.install'
backup=(etc/bluetooth/{main,rfcomm,audio,network,input}.conf
etc/conf.d/bluetooth)
source=("http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2"
- 'bluetooth.conf.d'
- 'runit.bluetooth')
+ bluetooth.conf.d run.bluetoothd run.sdpd run.hidd run.dund run.pand
+ run.rfcomm run.hid2hci)
+
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr \
@@ -45,9 +47,21 @@ build() {
install -D -m644 "$srcdir/$pkgname-$pkgver/network/network.conf" "$pkgdir/etc/bluetooth/" || return 1
install -D -m644 "$srcdir/$pkgname-$pkgver/input/input.conf" "$pkgdir/etc/bluetooth/" || return 1
install -D -m644 "$srcdir/$pkgname-$pkgver/audio/audio.conf" "$pkgdir/etc/bluetooth/" || return 1
- install -D -m755 "$srcdir/runit.bluetooth" "$pkgdir/etc/sv/bluetooth/run" || return 1
- install -D -m644 "$srcdir/bluetooth.conf.d" "$pkgdir/etc/conf.d/bluetooth" || return 1
+ install -D -m644 "$srcdir/bluetooth.conf.d" "$pkgdir/etc/conf.d/bluetooth" || return 1
+ install -D -m755 "$srcdir/run.bluetoothd" "$pkgdir/etc/sv/bluetoothd/run" || return 1
+ install -D -m755 "$srcdir/run.sdpd" "$pkgdir/etc/sv/sdpd/run" || return 1
+ install -D -m755 "$srcdir/run.hidd" "$pkgdir/etc/sv/hidd/run" || return 1
+ install -D -m755 "$srcdir/run.dund" "$pkgdir/etc/sv/dund/run" || return 1
+ install -D -m755 "$srcdir/run.pand" "$pkgdir/etc/sv/pand/run" || return 1
+ install -D -m755 "$srcdir/run.rfcomm" "$pkgdir/etc/sv/rfcomm/run" || return 1
+ install -D -m755 "$srcdir/run.hid2hci" "$pkgdir/etc/sv/hid2hci/run" || return 1
}
md5sums=('3c2187a97f5b43ae84b4bbd4b34671e0'
'd12be5b494525bb1ba6eac5c3983dd3e'
- 'af1037c8e96dda60a1fea29140afb8f4')
+ '1c88fcd455920ad8ee0c7cae3fe15771'
+ 'fc8cdfd1fb0044a674b79c41d5d88388'
+ '2483128d1cb93aeaf15d66058c052dc2'
+ '95bfe0ff91559d719e5feecb0388b4e1'
+ 'b130f90a3cab7dd8a40c558d95c540a2'
+ 'a416cdf7cc7c954f6b09d6c2a1d1c0d3'
+ 'dd046ee5a232ba7cdbe8006d90b479e5')