summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/foldingathome/foldingathome.install
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-26 19:35:29 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-26 19:35:29 (GMT)
commit6980e3d3f5dbc51bd787c2ad490dc7b3c160199c (patch)
tree30395623abc4d387d688d82effbe1e76358c773b /abs/extra-testing/community/foldingathome/foldingathome.install
parent1c50f83d6e7d4b0f5bdff9edd9e3a71a25abe423 (diff)
downloadlinhes_pkgbuild-6980e3d3f5dbc51bd787c2ad490dc7b3c160199c.zip
linhes_pkgbuild-6980e3d3f5dbc51bd787c2ad490dc7b3c160199c.tar.gz
linhes_pkgbuild-6980e3d3f5dbc51bd787c2ad490dc7b3c160199c.tar.bz2
Initial PKGBUILD for Folding at Home.
Diffstat (limited to 'abs/extra-testing/community/foldingathome/foldingathome.install')
-rwxr-xr-xabs/extra-testing/community/foldingathome/foldingathome.install30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/extra-testing/community/foldingathome/foldingathome.install b/abs/extra-testing/community/foldingathome/foldingathome.install
new file mode 100755
index 0000000..8eedb6c
--- /dev/null
+++ b/abs/extra-testing/community/foldingathome/foldingathome.install
@@ -0,0 +1,30 @@
+# arg 1: the new package version
+post_install() {
+ cat << 'EOM'
+ --> Please cd to /opt/fah/ and execute ./fah6 -smp -configonly
+ --> to configure your settings. Then add "foldingathome" to the list
+ --> of daemons in /etc/rc.conf. If you would like to join the Arch
+ --> Linux team, use team number 45032. To check current progress,
+ --> point your browser to file://opt/fah/MyFolding.html
+
+ --> It is strongly recommended that you run foldingathome as a user other
+ --> than root. You can identify a user in /etc/conf.d/foldingathome.
+ --> A directory called /opt/fah/$FAH_USER will be created."
+EOM
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+
+$op $*