summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/gstreamer0.10-base/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-03-08 00:02:33 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-03-08 00:02:33 (GMT)
commit028e57e8aa48ea8496e5506b2a2c47d25fa5085d (patch)
treed10c7d06211a0b351fe69291d76536fb204f2b74 /abs/extra-testing/community/gstreamer0.10-base/PKGBUILD
parent24bf31183a714449ee1ae6d93283722ae4f55e6d (diff)
downloadlinhes_pkgbuild-028e57e8aa48ea8496e5506b2a2c47d25fa5085d.zip
linhes_pkgbuild-028e57e8aa48ea8496e5506b2a2c47d25fa5085d.tar.gz
linhes_pkgbuild-028e57e8aa48ea8496e5506b2a2c47d25fa5085d.tar.bz2
Initial inclusion into community. Needed for gnash, etc...
Diffstat (limited to 'abs/extra-testing/community/gstreamer0.10-base/PKGBUILD')
-rw-r--r--abs/extra-testing/community/gstreamer0.10-base/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/extra-testing/community/gstreamer0.10-base/PKGBUILD b/abs/extra-testing/community/gstreamer0.10-base/PKGBUILD
new file mode 100644
index 0000000..b1b065d
--- /dev/null
+++ b/abs/extra-testing/community/gstreamer0.10-base/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 14433 2008-10-06 17:33:22Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=gstreamer0.10-base
+pkgver=0.10.21
+pkgrel=1
+pkgdesc="GStreamer Multimedia Framework Base plugin libraries"
+arch=(i686 x86_64)
+license=('GPL' 'LGPL')
+depends=('gstreamer0.10>=0.10.21' 'liboil>=0.3.15' 'libsm' 'libxv')
+makedepends=('pkgconfig')
+options=(!libtool)
+url="http://gstreamer.freedesktop.org/"
+_relname=gst-plugins-base
+source=(${url}/src/${_relname}/${_relname}-${pkgver}.tar.bz2)
+md5sums=('0e0cd485311502ad1c0c028148e3186a')
+
+build() {
+ cd ${startdir}/src/${_relname}-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-static --enable-experimental --disable-external \
+ --disable-docs-build --disable-plugin-docs \
+ --with-package-name="GStreamer Base Plugins (Archlinux)" \
+ --with-package-origin="http://www.archlinux.org/" || return 1
+
+ make || return 1
+ make DESTDIR=${startdir}/pkg install || return 1
+}