summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/libelf/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-01 20:39:05 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-01 20:39:05 (GMT)
commitf2f661dad3f31c477f51d0165f29d9ba19a411c3 (patch)
tree40128952f2c5e445fb7a556279f630a06eb1c7e0 /abs/extra-testing/community/libelf/PKGBUILD
parent58048a619b315549848b0676431729dc78dc499f (diff)
parentc00e83b16e3dd048c2396b57531a7cec40189a39 (diff)
downloadlinhes_pkgbuild-f2f661dad3f31c477f51d0165f29d9ba19a411c3.zip
linhes_pkgbuild-f2f661dad3f31c477f51d0165f29d9ba19a411c3.tar.gz
linhes_pkgbuild-f2f661dad3f31c477f51d0165f29d9ba19a411c3.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/extra-testing/community/libelf/PKGBUILD')
-rw-r--r--abs/extra-testing/community/libelf/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/abs/extra-testing/community/libelf/PKGBUILD b/abs/extra-testing/community/libelf/PKGBUILD
new file mode 100644
index 0000000..0cf517b
--- /dev/null
+++ b/abs/extra-testing/community/libelf/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 20525 2008-12-05 13:31:11Z jgc $
+# Maintainer: arjan <arjan@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=libelf
+pkgver=0.8.10
+pkgrel=3
+pkgdesc="libelf is a free ELF object file access library"
+arch=(i686 x86_64)
+license=('GPL')
+source=(http://www.mr511.de/software/${pkgname}-${pkgver}.tar.gz)
+url="http://directory.fsf.org/libs/misc/libelf.html"
+depends=('glibc')
+md5sums=('9db4d36c283d9790d8fa7df1f4d7b4d9')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --enable-shared \
+ --enable-gnu-names --enable-compat || return 1
+ make || return 1
+ make prefix="${pkgdir}/usr" install || return 1
+}