summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/libshout
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-14 05:24:05 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-14 05:24:05 (GMT)
commitc70a79c1e2deec8d508f34776befe11dab701e49 (patch)
treee316035b1059e5e4c3985fa64e7a3fa98ad697db /abs/extra-testing/community/libshout
parentc7d4d0ec62e50c879908ab9f5e6b82c59124d338 (diff)
downloadlinhes_pkgbuild-c70a79c1e2deec8d508f34776befe11dab701e49.zip
linhes_pkgbuild-c70a79c1e2deec8d508f34776befe11dab701e49.tar.gz
linhes_pkgbuild-c70a79c1e2deec8d508f34776befe11dab701e49.tar.bz2
Adding missing PKGBUILDS, needed for VLC.
fluidsynth libdvbpsi libmatroska libmodplug libmpcded libshout libv4l lua zvbi
Diffstat (limited to 'abs/extra-testing/community/libshout')
-rw-r--r--abs/extra-testing/community/libshout/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra-testing/community/libshout/PKGBUILD b/abs/extra-testing/community/libshout/PKGBUILD
new file mode 100644
index 0000000..b23c88e
--- /dev/null
+++ b/abs/extra-testing/community/libshout/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 19191 2008-11-17 11:43:24Z jgc $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: arjan <arjan@archlinux.org>
+# Contributor: Jason Chu <jchu@xentac.net>
+
+pkgname=libshout
+pkgver=2.2.2
+pkgrel=2
+pkgdesc="Library for accessing a shoutcast/icecast server"
+arch=('i686' 'x86_64')
+depends=('libvorbis' 'libtheora' 'speex')
+url="http://www.icecast.org/"
+options=('!libtool' 'force')
+license=('LGPL2')
+source=(http://downloads.xiph.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('4f75fc9901c724b712c371c9a1e782d3')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var || return 1
+ make LDFLAGS+=-lspeex || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+}