summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/screen/screen.install
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-01 20:39:05 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-01 20:39:05 (GMT)
commitf2f661dad3f31c477f51d0165f29d9ba19a411c3 (patch)
tree40128952f2c5e445fb7a556279f630a06eb1c7e0 /abs/extra-testing/community/screen/screen.install
parent58048a619b315549848b0676431729dc78dc499f (diff)
parentc00e83b16e3dd048c2396b57531a7cec40189a39 (diff)
downloadlinhes_pkgbuild-f2f661dad3f31c477f51d0165f29d9ba19a411c3.zip
linhes_pkgbuild-f2f661dad3f31c477f51d0165f29d9ba19a411c3.tar.gz
linhes_pkgbuild-f2f661dad3f31c477f51d0165f29d9ba19a411c3.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/extra-testing/community/screen/screen.install')
-rw-r--r--abs/extra-testing/community/screen/screen.install27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/extra-testing/community/screen/screen.install b/abs/extra-testing/community/screen/screen.install
new file mode 100644
index 0000000..51bd6a7
--- /dev/null
+++ b/abs/extra-testing/community/screen/screen.install
@@ -0,0 +1,27 @@
+
+pre_upgrade() {
+ pre_remove $*
+}
+
+pre_remove() {
+ compiled="/usr/share/terminfo/s/screen-256color"
+ if [ -e $compiled ]; then
+ if pacman -Qo $compiled 2>&1 | grep "No package owns" >/dev/null; then
+ echo -n "removing compiled terminfo..."
+ rm -f $compiled
+ echo "done."
+ fi
+ fi
+ compiled="/usr/share/terminfo/s/screen-256color-bce"
+ if [ -e $compiled ]; then
+ if pacman -Qo $compiled 2>&1 | grep "No package owns" >/dev/null; then
+ echo -n "removing compiled terminfo..."
+ rm -f $compiled
+ echo "done."
+ fi
+ fi
+}
+
+op=$1
+shift
+$op $*