summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/unrar/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-02-05 03:57:53 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-02-05 03:57:53 (GMT)
commit7b79ae29153ab199c26f795302c21c611a41586c (patch)
tree4227f09f113772180afcffe89e0db518a0570a60 /abs/extra-testing/community/unrar/PKGBUILD
parent89b1295c5748aa24898ae8ba710b9d85a2b83b81 (diff)
downloadlinhes_pkgbuild-7b79ae29153ab199c26f795302c21c611a41586c.zip
linhes_pkgbuild-7b79ae29153ab199c26f795302c21c611a41586c.tar.gz
linhes_pkgbuild-7b79ae29153ab199c26f795302c21c611a41586c.tar.bz2
Items for "community".
Diffstat (limited to 'abs/extra-testing/community/unrar/PKGBUILD')
-rw-r--r--abs/extra-testing/community/unrar/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra-testing/community/unrar/PKGBUILD b/abs/extra-testing/community/unrar/PKGBUILD
new file mode 100644
index 0000000..6b68616
--- /dev/null
+++ b/abs/extra-testing/community/unrar/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 18913 2008-11-10 11:16:31Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: dorphell <dorphell@gmx.net>
+
+pkgname=unrar
+pkgver=3.8.5
+pkgrel=1
+pkgdesc="The RAR uncompression program"
+arch=('i686' 'x86_64')
+depends=('gcc-libs')
+url="http://rarlab.com"
+license=('custom')
+replaces=('rar')
+source=(http://www.rarlab.com/rar/unrarsrc-${pkgver}.tar.gz)
+md5sums=('875688e6a144a3f75d2a6a0da3e43f8b')
+
+build() {
+ cd ${srcdir}/${pkgname}
+ make -f makefile.unix
+ install -Dm755 unrar ${pkgdir}/usr/bin/unrar
+ # install license
+ install -Dm644 license.txt ${pkgdir}/usr/share/licenses/$pkgname/license.txt
+}