summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-06-01 02:10:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-06-01 02:10:09 (GMT)
commitd7a06c882ef45d014319f98daf8e0dbe5599321d (patch)
tree08283d317915d613a4ea86513e8b8f626ceb243e /abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch
parent6aec480f40e73de0b179d0a91aa484266190f52b (diff)
parente9dc867012dd4553eeca9a67837688e762fcded6 (diff)
downloadlinhes_pkgbuild-d7a06c882ef45d014319f98daf8e0dbe5599321d.zip
linhes_pkgbuild-d7a06c882ef45d014319f98daf8e0dbe5599321d.tar.gz
linhes_pkgbuild-d7a06c882ef45d014319f98daf8e0dbe5599321d.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD into linhes-config-python
* 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD: lirc: pkg bump to just make it different then the submitted version in the ticket. lirc: change modmce patch to version 1.5 glass-wide: adding theme irqbalance: adding pkg fakeroot: add package linhes-scripts: adding idle.sh Bumped xbmc-svn to 20449 plus added common remote support fresh build bumped mythtv-svn to 20586 First cut at XBMC (svn with vdpau) updated libjpeg and added libsamplerate for XBMC build mythtv-svn bumped for new qt4 qt updated to 4.5.1 which: pkg bump used for testing, no functional changes. Bumped version to recompile. Bumped version for birthday present to community. Conflicts: abs/core-testing/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch')
-rw-r--r--abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch b/abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch
new file mode 100644
index 0000000..d112e52
--- /dev/null
+++ b/abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch
@@ -0,0 +1,23 @@
+Index: xbmc/Application.cpp
+===================================================================
+--- xbmc/Application.cpp (revision 20059)
++++ xbmc/Application.cpp (working copy)
+@@ -873,6 +873,8 @@
+ #endif
+
+ // set GUI res and force the clear of the screen
++ if (g_guiSettings.GetBool("videoscreen.safefull"))
++ g_guiSettings.m_LookAndFeelResolution = AUTORES;
+ g_graphicsContext.SetVideoResolution(g_guiSettings.m_LookAndFeelResolution, TRUE, true);
+
+ #ifdef _WIN32PC
+@@ -949,6 +951,9 @@
+ time(&seconds);
+ srand((unsigned int)seconds);
+
++ if (g_guiSettings.GetBool("videoscreen.safefull"))
++ g_graphicsContext.ToggleFullScreenRoot();
++
+ return CXBApplicationEx::Create(hWnd);
+ }
+