summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/cpufreqd/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-03-22 17:27:27 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-03-22 17:27:27 (GMT)
commite51cf415764a2c267f373965c48eec082ad59d81 (patch)
tree3b17b5b571cc0bf57e8390bb72b7137d6cdb7b33 /abs/extra-testing/cpufreqd/PKGBUILD
parent13cda940b116339e3d5b5f27e73ad3f8dd2554e9 (diff)
downloadlinhes_pkgbuild-e51cf415764a2c267f373965c48eec082ad59d81.zip
linhes_pkgbuild-e51cf415764a2c267f373965c48eec082ad59d81.tar.gz
linhes_pkgbuild-e51cf415764a2c267f373965c48eec082ad59d81.tar.bz2
cpufreq and utils: intial import
refs 492
Diffstat (limited to 'abs/extra-testing/cpufreqd/PKGBUILD')
-rw-r--r--abs/extra-testing/cpufreqd/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/extra-testing/cpufreqd/PKGBUILD b/abs/extra-testing/cpufreqd/PKGBUILD
new file mode 100644
index 0000000..a727e28
--- /dev/null
+++ b/abs/extra-testing/cpufreqd/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 60269 2009-12-02 16:30:29Z giovanni $
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Kevin Piche <kevin@archlinux.org>
+# Contributor: Manolis Tzanidakis <manolis@archlinux.org>
+
+pkgname=cpufreqd
+pkgver=2.3.4
+pkgrel=2
+pkgdesc="A small daemon to adjust cpu speed (and indeed voltage)"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/cpufreqd"
+license=('GPL2')
+depends=('cpufrequtils')
+install="$pkgname.install"
+backup=(etc/cpufreqd.conf)
+options=('!libtool')
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2
+ 'cpufreqd')
+md5sums=('f4193f688305566a8422dd3989667668'
+ 'ae7b0ec1e8e9f9e7f05fb83749af4ed4')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc
+ make || return 1
+ make DESTDIR=$pkgdir install
+
+ install -D -m 755 $srcdir/cpufreqd $pkgdir/etc/rc.d/cpufreqd || return 1
+}