summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/dnsmasq/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verison.net>2010-03-19 00:08:12 (GMT)
committerMichael Hanson <hansonorders@verison.net>2010-03-19 00:08:12 (GMT)
commit0c810798e72af9cd3cb88de1b79b2a901bad3963 (patch)
tree3f6ef2600e769c41f9da475ea357895c134cf747 /abs/extra-testing/dnsmasq/PKGBUILD
parent896e8723af0a99e741d6d767c13b4aa52f20820c (diff)
parent948970dc8ce2e250324747bf0499c78acfd78912 (diff)
downloadlinhes_pkgbuild-0c810798e72af9cd3cb88de1b79b2a901bad3963.zip
linhes_pkgbuild-0c810798e72af9cd3cb88de1b79b2a901bad3963.tar.gz
linhes_pkgbuild-0c810798e72af9cd3cb88de1b79b2a901bad3963.tar.bz2
Merge branch 'master' of mihanson@knoppmyth.net:LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/dnsmasq/PKGBUILD')
-rw-r--r--abs/extra-testing/dnsmasq/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/abs/extra-testing/dnsmasq/PKGBUILD b/abs/extra-testing/dnsmasq/PKGBUILD
new file mode 100644
index 0000000..a413df4
--- /dev/null
+++ b/abs/extra-testing/dnsmasq/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id: PKGBUILD 66607 2010-02-01 01:42:17Z giovanni $
+# Maintainer: Paul Mattal <paul@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=dnsmasq
+pkgver=2.52
+pkgrel=1
+pkgdesc="Lightweight, easy to configure DNS forwarder and DHCP server"
+url="http://www.thekelleys.org.uk/dnsmasq/doc.html"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('glibc' 'bash')
+makedepends=('libcap>=2.16')
+backup=('etc/dnsmasq.conf')
+install=
+source=("http://www.thekelleys.org.uk/$pkgname/$pkgname-$pkgver.tar.gz"
+ 'rc.dnsmasq')
+md5sums=('1bb32fffdb4f977ead607802b5d701d0' 'e956eee1ec24212a3254d2b168187495')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ # Build
+ make || return 1
+
+ # Install
+ install -d $pkgdir/etc/rc.d || return 1
+ make PREFIX=/usr DESTDIR=$pkgdir install || return 1
+
+ install -D -m755 \
+ $srcdir/rc.dnsmasq $pkgdir/etc/rc.d/dnsmasq || return 1
+ install -D -m644 \
+ dnsmasq.conf.example $pkgdir/etc/dnsmasq.conf || return 1
+
+ # Make the Required Directories for DHCP Server Default Directories
+ install -d $pkgdir/var/db || return 1
+ install -d $pkgdir/var/lib/misc || return 1
+}
+
+# vim: ts=2 sw=2 et ft=sh