summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/doxygen/PKGBUILD.orig
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verison.net>2010-07-16 21:34:02 (GMT)
committerMichael Hanson <hansonorders@verison.net>2010-07-16 21:34:02 (GMT)
commit90dc1e473633dfb15c9644caf11e368662ad0d26 (patch)
tree04580e04cafb5e474772832edb83fdd825327f67 /abs/extra-testing/doxygen/PKGBUILD.orig
parent45b265e6a0c9ec2cdec57e63d840aad881a5ef41 (diff)
downloadlinhes_pkgbuild-90dc1e473633dfb15c9644caf11e368662ad0d26.zip
linhes_pkgbuild-90dc1e473633dfb15c9644caf11e368662ad0d26.tar.gz
linhes_pkgbuild-90dc1e473633dfb15c9644caf11e368662ad0d26.tar.bz2
doxygen: update to 1.71 ref 647
Diffstat (limited to 'abs/extra-testing/doxygen/PKGBUILD.orig')
-rw-r--r--abs/extra-testing/doxygen/PKGBUILD.orig24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/extra-testing/doxygen/PKGBUILD.orig b/abs/extra-testing/doxygen/PKGBUILD.orig
new file mode 100644
index 0000000..f4b09d2
--- /dev/null
+++ b/abs/extra-testing/doxygen/PKGBUILD.orig
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 14308 2008-10-05 15:59:28Z dan $
+# Maintainer: Dan McGee <dan@archlinux.org>
+pkgname=doxygen
+pkgver=1.7.1
+pkgrel=1
+pkgdesc="A documentation system for C++, C, Java, IDL and PHP"
+license=('GPL')
+arch=(i686 x86_64)
+url="http://www.doxygen.org/"
+depends=('gcc-libs')
+# qt required to build and run doxywizard, but don't want to drag it in
+makedepends=('flex' 'qt3')
+optdepends=('graphviz: for caller/callee graph generation'
+ 'qt3: for doxywizard')
+source=(ftp://ftp.stack.nl/pub/users/dimitri/${pkgname}-${pkgver}.src.tar.gz)
+
+build() {
+ . /etc/profile.d/qt3.sh
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix /usr --with-doxywizard
+ make || return 1
+ make INSTALL=${startdir}/pkg/usr MAN1DIR=share/man/man1 install
+}
+md5sums=('13e76e10fb55581a16ee04de35c264f0')