summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/fceu/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2008-12-11 01:30:53 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2008-12-11 01:30:53 (GMT)
commit8417e5e3b118ed9e12563a3d4fceeb38b9e73d4f (patch)
tree99edff3d756441a12087ecd5053d9ca60536beff /abs/extra-testing/fceu/PKGBUILD
parente649efa24662af962e6cbd7b9ece1bdd8f6a9340 (diff)
downloadlinhes_pkgbuild-8417e5e3b118ed9e12563a3d4fceeb38b9e73d4f.zip
linhes_pkgbuild-8417e5e3b118ed9e12563a3d4fceeb38b9e73d4f.tar.gz
linhes_pkgbuild-8417e5e3b118ed9e12563a3d4fceeb38b9e73d4f.tar.bz2
Deps for emulators and Miro.
Diffstat (limited to 'abs/extra-testing/fceu/PKGBUILD')
-rwxr-xr-xabs/extra-testing/fceu/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/extra-testing/fceu/PKGBUILD b/abs/extra-testing/fceu/PKGBUILD
new file mode 100755
index 0000000..cdae29a
--- /dev/null
+++ b/abs/extra-testing/fceu/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Eric Belanger <belanger@astro.umontreal.ca>
+# Contributor: Jo Christian Bergskås <jcberg@gmail.com>
+
+pkgname=fceu
+pkgver=0.98.15
+pkgrel=1
+pkgdesc="FCE Ultra is a fast and ultra-compatible NES/Famicom emulator with SDL, OpenGL and SVGALIB support."
+arch=('i686' 'x86_64')
+url="http://fceultra.sourceforge.net"
+license="GPL"
+options=('docs')
+depends=('sdl' 'zlib')
+source=(ftp://ftp.knoppmyth.net/R6/sources/$pkgname-$pkgver-src.tar.bz2)
+md5sums=('bfe9aa7f91c19fa17bb6e5424dc5901b')
+
+build() {
+ cd $startdir/src/fceu
+ ./configure --prefix=/usr --with-opengl --build=i686-linux-gnu
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+ install -D -m644 $startdir/src/fceu/Documentation/fceu-sdl.6 $startdir/pkg/usr/man/man6/fceu.6
+ install -d $startdir/pkg/usr/share/doc/fceu-doc
+ cp -r $startdir/src/fceu/Documentation/* $startdir/pkg/usr/share/doc/fceu-doc
+}