summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/fuppes-svn/fuppes.diff
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-06-01 02:10:45 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-06-01 02:10:45 (GMT)
commitf01297f70fbbf345e11edcf8f1d5fb77c6d2a6ed (patch)
tree1babc4291a4cd3d72ce7e595212a273318e33018 /abs/extra-testing/fuppes-svn/fuppes.diff
parentd7a06c882ef45d014319f98daf8e0dbe5599321d (diff)
parent528268bf6b14f8e3c9f4941d5587d982ff1892d6 (diff)
downloadlinhes_pkgbuild-f01297f70fbbf345e11edcf8f1d5fb77c6d2a6ed.zip
linhes_pkgbuild-f01297f70fbbf345e11edcf8f1d5fb77c6d2a6ed.tar.gz
linhes_pkgbuild-f01297f70fbbf345e11edcf8f1d5fb77c6d2a6ed.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD into linhes-config-python
* 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD: runit-scripts: update the lircd run script to use the dvicoIR sym link lirc: update PKGBUILD to install dvico udev rule lirc: add udev rule for the dvico remote lirc: added support for other mce remotes Added patch needed for FUPPES for compile. Initial inclusion, needed for fuppes. Updated to fuppes-svn. Removed fuppes. Latest version. Closes FS 365. Fixed typo. Included ffpresets. Closes FS #359. Bumped to ensure latest -fixes. Bumped to ensure latest -fixes. Bumped for latest -fixes. Bumped to latest fixes and VDPAU 20549 patch.
Diffstat (limited to 'abs/extra-testing/fuppes-svn/fuppes.diff')
-rw-r--r--abs/extra-testing/fuppes-svn/fuppes.diff25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/extra-testing/fuppes-svn/fuppes.diff b/abs/extra-testing/fuppes-svn/fuppes.diff
new file mode 100644
index 0000000..9b7b6a8
--- /dev/null
+++ b/abs/extra-testing/fuppes-svn/fuppes.diff
@@ -0,0 +1,25 @@
+--- src/plugins/ffmpeg/ffmpeg.cpp.orig 2009-05-29 20:12:09.000000000 +0000
++++ src/plugins/ffmpeg/ffmpeg.cpp 2009-05-29 20:10:01.000000000 +0000
+@@ -1021,19 +1021,9 @@
+ if (subtitle_to_free) {
+ if (subtitle_to_free->rects != NULL) {
+ for (i = 0; i < subtitle_to_free->num_rects; i++) {
+-
+-#ifndef LIBAVCODEC_VERSION_MINOR
+-#define LIBAVCODEC_VERSION_MINOR 0
+-#endif
+-
+-#if LIBAVCODEC_VERSION_MINOR >= 11
+- av_freep(subtitle_to_free->rects[i]->pict.data[0]);
+- av_freep(subtitle_to_free->rects[i]->pict.data[1]);
+- av_freep(subtitle_to_free->rects[i]);
+-#else
+- av_free(subtitle_to_free->rects[i].bitmap);
+- av_free(subtitle_to_free->rects[i].rgba_palette);
+-#endif
++ av_freep(&subtitle_to_free->rects[i]->pict.data[0]);
++ av_freep(&subtitle_to_free->rects[i]->pict.data[1]);
++ av_freep(&subtitle_to_free->rects[i]);
+ }
+ av_freep(&subtitle_to_free->rects);
+ }