summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/gdk-pixbuf/gdk-pixbuf-0.22.0-bmp_secure.patch
diff options
context:
space:
mode:
authorBob Igo <bob@stormlogic.com>2009-01-17 17:54:02 (GMT)
committerBob Igo <bob@stormlogic.com>2009-01-17 17:54:02 (GMT)
commit100e02faeb525e8f697b0c8c6bc4a3eb2179c8b3 (patch)
tree720dc08fc5feddfd8934ecdcd79fdd703922956e /abs/extra-testing/gdk-pixbuf/gdk-pixbuf-0.22.0-bmp_secure.patch
parent18b8c17f24b9cd6d9600b212cbd615deb69fe500 (diff)
parentcff24d02505081b7297a257c38edcf286772e015 (diff)
downloadlinhes_pkgbuild-100e02faeb525e8f697b0c8c6bc4a3eb2179c8b3.zip
linhes_pkgbuild-100e02faeb525e8f697b0c8c6bc4a3eb2179c8b3.tar.gz
linhes_pkgbuild-100e02faeb525e8f697b0c8c6bc4a3eb2179c8b3.tar.bz2
Merge branch 'master' of ssh://igo@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/gdk-pixbuf/gdk-pixbuf-0.22.0-bmp_secure.patch')
-rw-r--r--abs/extra-testing/gdk-pixbuf/gdk-pixbuf-0.22.0-bmp_secure.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/abs/extra-testing/gdk-pixbuf/gdk-pixbuf-0.22.0-bmp_secure.patch b/abs/extra-testing/gdk-pixbuf/gdk-pixbuf-0.22.0-bmp_secure.patch
new file mode 100644
index 0000000..29471f1
--- /dev/null
+++ b/abs/extra-testing/gdk-pixbuf/gdk-pixbuf-0.22.0-bmp_secure.patch
@@ -0,0 +1,19 @@
+Index: io-bmp.c
+===================================================================
+RCS file: /cvs/gnome/gtk+/gdk-pixbuf/io-bmp.c,v
+retrieving revision 1.41
+diff -u -p -r1.41 io-bmp.c
+--- gdk-pixbuf/io-bmp.c 13 Aug 2004 02:26:57 -0000 1.41
++++ gdk-pixbuf/io-bmp.c 20 Aug 2004 00:18:14 -0000
+@@ -876,8 +876,10 @@ DoCompressed(struct bmp_progressive_stat
+ guchar c;
+ gint idx;
+
+- if (context->compr.y >= context->Header.height)
++ if (context->compr.y >= context->Header.height) {
++ context->BufferDone = 0;
+ return TRUE;
++ }
+
+ y = context->compr.y;
+