summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/gnome-python-extras/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-03 07:56:23 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-03 07:56:23 (GMT)
commit0ce6326882d1ef6b45955ce0af948aa3da22bc07 (patch)
tree6ef646f87190a95deea7641df53c6ee5396c900c /abs/extra-testing/gnome-python-extras/PKGBUILD
parent907606040ebd98338b939452ee37698b62718820 (diff)
downloadlinhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.zip
linhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.tar.gz
linhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.tar.bz2
Added support for Miro.
Diffstat (limited to 'abs/extra-testing/gnome-python-extras/PKGBUILD')
-rw-r--r--abs/extra-testing/gnome-python-extras/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/extra-testing/gnome-python-extras/PKGBUILD b/abs/extra-testing/gnome-python-extras/PKGBUILD
new file mode 100644
index 0000000..d169b8f
--- /dev/null
+++ b/abs/extra-testing/gnome-python-extras/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 16741 2008-10-22 03:06:30Z allan $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=gnome-python-extras
+pkgver=2.19.1
+pkgrel=3
+pkgdesc="Gnome Python interfaces for libraries not part of the core platform"
+arch=(i686 x86_64)
+license=('GPL' 'LGPL')
+depends=('gnome-python>=2.22.1')
+makedepends=('libgtkhtml' 'gtkspell' 'gdl' 'xulrunner>=1.9' 'libgksu' 'pkgconfig')
+options=('!libtool')
+source=(http://ftp.gnome.org/pub/gnome/sources/gnome-python-extras/2.19/gnome-python-extras-${pkgver}.tar.bz2
+ gnome-python-extras-2.19.1-pkg-config.patch
+ gnome-python-extras-2.19.1-xulrunner.patch)
+url="http://www.daa.com.au/~james/pygtk/"
+md5sums=('08896c63d71ce44d20fafbaf9c0edc78'
+ 'be993cc1e60c090c58db8317a1862213'
+ '73657335e522f361d08ccc4899d279d6')
+
+build() {
+ cd ${startdir}/src/gnome-python-extras-${pkgver}
+ patch -Np1 -i ${srcdir}/gnome-python-extras-2.19.1-pkg-config.patch || return 1
+ patch -Np1 -i ${srcdir}/gnome-python-extras-2.19.1-xulrunner.patch || return 1
+ sed -i "s|#include <gdl/gdl-icons.h>||" gdl/gdl.override || return 1
+ ./configure --prefix=/usr --with-gtkmozembed=xulrunner || return 1
+ make MOZILLA_HOME=/usr/lib/xulrunner-1.9 || return 1
+ make DESTDIR=${startdir}/pkg install || return 1
+}