summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/gnome-vfs
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-03 07:56:23 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-03 07:56:23 (GMT)
commit0ce6326882d1ef6b45955ce0af948aa3da22bc07 (patch)
tree6ef646f87190a95deea7641df53c6ee5396c900c /abs/extra-testing/gnome-vfs
parent907606040ebd98338b939452ee37698b62718820 (diff)
downloadlinhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.zip
linhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.tar.gz
linhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.tar.bz2
Added support for Miro.
Diffstat (limited to 'abs/extra-testing/gnome-vfs')
-rw-r--r--abs/extra-testing/gnome-vfs/PKGBUILD39
-rw-r--r--abs/extra-testing/gnome-vfs/gnome-vfs.install22
-rw-r--r--abs/extra-testing/gnome-vfs/hal-show-volume-names.patch46
3 files changed, 107 insertions, 0 deletions
diff --git a/abs/extra-testing/gnome-vfs/PKGBUILD b/abs/extra-testing/gnome-vfs/PKGBUILD
new file mode 100644
index 0000000..dc848be
--- /dev/null
+++ b/abs/extra-testing/gnome-vfs/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id: PKGBUILD 20541 2008-12-05 16:30:04Z allan $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=gnome-vfs
+pkgver=2.24.0
+pkgrel=2
+pkgdesc="The GNOME Virtual File System"
+arch=(i686 x86_64)
+license=('LGPL')
+depends=('fam' 'gconf>=2.24' 'hal>=0.5.11' 'bzip2' 'avahi>=0.6.23' 'smbclient>=3.0.31' 'gnome-mime-data>=2.18.0-2' 'heimdal>=1.2' 'gnutls>=2.4.1')
+makedepends=('perlxml' 'pkgconfig' 'intltool')
+options=('!libtool' '!emptydirs')
+conflicts=(gnome-vfs-samba)
+provides=(gnome-vfs-samba)
+replaces=(gnome-vfs-samba gnome-vfs-extras)
+url="http://www.gnome.org"
+install=gnome-vfs.install
+source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/2.24/gnome-vfs-${pkgver}.tar.bz2
+ hal-show-volume-names.patch)
+md5sums=('870ee8861bfcaeb852934e95657ef83e' '109d07aa1dc8cb6523c47c4984047dce')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ #Archlinux patch (b.g.o #321498)
+ patch -Np1 -i ${startdir}/src/hal-show-volume-names.patch || return 1
+
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --disable-static \
+ --libexecdir=/usr/lib/gnome-vfs-2.0 \
+ --enable-samba --enable-hal \
+ --enable-avahi --disable-howl \
+ --disable-openssl --enable-gnutls
+ make || return 1
+ make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR=${startdir}/pkg install || return 1
+
+ mkdir -p ${startdir}/pkg/usr/share/gconf/schemas
+ gconf-merge-schema ${startdir}/pkg/usr/share/gconf/schemas/${pkgname}.schemas ${startdir}/pkg/etc/gconf/schemas/*.schemas
+ rm -f ${startdir}/pkg/etc/gconf/schemas/*.schemas
+}
diff --git a/abs/extra-testing/gnome-vfs/gnome-vfs.install b/abs/extra-testing/gnome-vfs/gnome-vfs.install
new file mode 100644
index 0000000..0a77ef7
--- /dev/null
+++ b/abs/extra-testing/gnome-vfs/gnome-vfs.install
@@ -0,0 +1,22 @@
+pkgname=gnome-vfs
+
+post_install() {
+ usr/sbin/gconfpkg --install ${pkgname}
+}
+
+pre_upgrade() {
+ pre_remove $1
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ usr/sbin/gconfpkg --uninstall ${pkgname}
+}
+
+op=$1
+shift
+
+$op $*
diff --git a/abs/extra-testing/gnome-vfs/hal-show-volume-names.patch b/abs/extra-testing/gnome-vfs/hal-show-volume-names.patch
new file mode 100644
index 0000000..5b8420c
--- /dev/null
+++ b/abs/extra-testing/gnome-vfs/hal-show-volume-names.patch
@@ -0,0 +1,46 @@
+Index: gnome-vfs-hal-mounts.c
+===================================================================
+RCS file: /cvs/gnome/gnome-vfs/libgnomevfs/gnome-vfs-hal-mounts.c,v
+retrieving revision 1.33
+diff -u -p -r1.33 gnome-vfs-hal-mounts.c
+--- gnome-vfs/libgnomevfs/gnome-vfs-hal-mounts.c 7 Jul 2006 15:56:57 -0000 1.33
++++ gnome-vfs/libgnomevfs/gnome-vfs-hal-mounts.c 14 Jul 2006 18:48:51 -0000
+@@ -877,6 +877,7 @@ _hal_add_volume (GnomeVFSVolumeMonitorDa
+ GnomeVFSDrive *drive;
+ GnomeVFSVolumeMonitor *volume_monitor;
+ char *name;
++ char *icon;
+ gboolean allowed_by_policy;
+ const char *backing_udi;
+
+@@ -975,6 +976,8 @@ _hal_add_volume (GnomeVFSVolumeMonitorDa
+ */
+ drive = _gnome_vfs_volume_monitor_find_drive_by_hal_udi (volume_monitor, libhal_volume_get_udi (hal_volume));
+ if (drive == NULL && allowed_by_policy) {
++ name = _hal_drive_policy_get_display_name (volume_monitor_daemon, hal_drive, hal_volume);
++ icon = _hal_drive_policy_get_icon (volume_monitor_daemon, hal_drive, hal_volume);
+ drive = g_object_new (GNOME_VFS_TYPE_DRIVE, NULL);
+ if (libhal_volume_disc_has_audio (hal_volume)) {
+ drive->priv->activation_uri = g_strdup_printf ("cdda://%s",
+@@ -989,16 +992,16 @@ _hal_add_volume (GnomeVFSVolumeMonitorDa
+ * So just set it to the empty string
+ */
+ drive->priv->activation_uri = g_strdup ("");
++ g_free (name);
++ name = _hal_volume_policy_get_display_name (volume_monitor_daemon, hal_drive, hal_volume);
++ g_free (icon);
++ icon = _hal_volume_policy_get_icon (volume_monitor_daemon, hal_drive, hal_volume);
+ }
+ drive->priv->is_connected = TRUE;
+ drive->priv->device_path = g_strdup (libhal_volume_get_device_file (hal_volume));
+ drive->priv->device_type = _hal_get_gnome_vfs_device_type (hal_drive);
+
+- /* TODO: could add an icon of a drive with media in it since this codepath only
+- * handles drives with media in them
+- */
+- drive->priv->icon = _hal_drive_policy_get_icon (volume_monitor_daemon, hal_drive, NULL);
+- name = _hal_drive_policy_get_display_name (volume_monitor_daemon, hal_drive, hal_volume);
++ drive->priv->icon = icon;
+ drive->priv->display_name = _gnome_vfs_volume_monitor_uniquify_drive_name (volume_monitor, name);
+ g_free (name);
+ name = g_utf8_casefold (drive->priv->display_name, -1);