summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/gpac/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-08 20:01:22 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-08 20:01:22 (GMT)
commit43ab3e988867e6fc34cd4737dca35defd1c88998 (patch)
tree7ecd04a0f0a1fc0bfbaa34dcfe52d417cd5da6b7 /abs/extra-testing/gpac/PKGBUILD
parent62a85af977dfdaa2c5650611e92d165ff96c39af (diff)
downloadlinhes_pkgbuild-43ab3e988867e6fc34cd4737dca35defd1c88998.zip
linhes_pkgbuild-43ab3e988867e6fc34cd4737dca35defd1c88998.tar.gz
linhes_pkgbuild-43ab3e988867e6fc34cd4737dca35defd1c88998.tar.bz2
fix for gpac
Diffstat (limited to 'abs/extra-testing/gpac/PKGBUILD')
-rwxr-xr-xabs/extra-testing/gpac/PKGBUILD64
1 files changed, 20 insertions, 44 deletions
diff --git a/abs/extra-testing/gpac/PKGBUILD b/abs/extra-testing/gpac/PKGBUILD
index a89db81..7f47c35 100755
--- a/abs/extra-testing/gpac/PKGBUILD
+++ b/abs/extra-testing/gpac/PKGBUILD
@@ -1,50 +1,26 @@
+# $Id: PKGBUILD,v 1.1 2008/07/16 09:37:15 allan Exp $
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Contributor: niQo
+
pkgname=gpac
-pkgver=0.4.2
-pkgrel=3
-arch=("i686")
+pkgver=0.4.4
+pkgrel=2
pkgdesc="A multimedia framework based on the MPEG-4 Systems standard"
+arch=('i686' 'x86_64')
url="http://gpac.sourceforge.net"
-options=(strip !docs !libtool !emptydirs)
-depends=('freetype2' 'spidermonkey' 'libjpeg' 'libpng' 'libmad' 'xvidcore' 'ffmpeg' 'libogg' 'faad2' 'libxml2' 'sdl' 'libvorbis' 'libtheora')
-source=(http://easynews.dl.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
-http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/${pkgname}-${pkgver}-patches.tar.bz2
-gpac-0.4.2-ffmpeg-errno.patch)
-md5sums=('834910b42ef007410fcc49a5acd4656b' '7c40146553ab621154e52a8c43344083')
+depends=('libxml2' 'alsa-lib' 'sdl' 'spidermonkey' 'libmad' \
+ 'faad2' 'xvidcore' 'ffmpeg' 'freeglut')
+license=('LGPL')
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('a5cb48ab85e9914d127fd8799b4b2e56')
build() {
- cd $pkgname
- patch -p1 -i $startdir/src/$pkgname-$pkgver-DESTDIR.patch
- patch -p0 -i $startdir/src/$pkgname-$pkgver-configure-ogg.patch
- patch -p1 -i $startdir/src/$pkgname-$pkgver-nostrip.patch
- patch -p1 -i $startdir/src/$pkgname-$pkgver-soname.patch
- patch -p1 -i $startdir/src/$pkgname-$pkgver-static-defs.patch
- patch -p1 -i $startdir/src/$pkgname-$pkgver-ffmpeg-snapshots-compat.patch
- patch -p1 -i $startdir/src/$pkgname-$pkgver-ffmpeg-errno.patch
- sed -i 's/ldconfig / /' Makefile
- sed -i 's/-Wall//' Makefile
- patch -p1 -i $startdir/src/$pkgname-$pkgver-pic.patch
- chmod +x configure
- sed -i -e 's/has_wx=yes/has_wx=no/' configure
- sed -i -e 's/osmozilla//g' applications/Makefile
- ./configure --prefix=/usr \
- --use-ogg=system \
- --use-vorbis=system \
- --use-theora=system \
- --use-ffmpeg=system \
- --use-xvid=system \
- --use-ft=system \
- --use-png=system \
- --use-js=system \
- --use-mad=system \
- --use-jpeg=system \
- --disable-wx
- make OPTCFLAGS="${CFLAGS}" || return 1
- make DESTDIR="${startdir}/pkg" install
- make DESTDIR="${startdir}/pkg" install-lib
- ln -sf MP4Box ${startdir}/pkg/usr/bin/mp4box
- ln -sf MP4Client ${startdir}/pkg/usr/bin/mp4client
- install -d ${startdir}/pkg/usr/man/man1
- cp doc/man/mp4box.1 ${startdir}/pkg/usr/man/man1
- cp doc/man/mp4client.1 ${startdir}/pkg/usr/man/man1
- cp doc/man/gpac.1 ${startdir}/pkg/usr/man/man1
+ cd "${srcdir}/${pkgname}"
+ chmod +x configure
+ sed -i 's#osmozilla##g' applications/Makefile
+ sed -i 's#"$(prefix)#"$(DESTDIR)$(prefix)#' applications/osmo4_wx/Makefile
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=${pkgdir}/ install-lib
+ make DESTDIR=${pkgdir}/ install
}