summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/htop
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/extra-testing/htop
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/extra-testing/htop')
-rw-r--r--abs/extra-testing/htop/ChangeLog8
-rw-r--r--abs/extra-testing/htop/PKGBUILD22
-rw-r--r--abs/extra-testing/htop/htop-treeview.patch12
3 files changed, 0 insertions, 42 deletions
diff --git a/abs/extra-testing/htop/ChangeLog b/abs/extra-testing/htop/ChangeLog
deleted file mode 100644
index 7d77d0b..0000000
--- a/abs/extra-testing/htop/ChangeLog
+++ /dev/null
@@ -1,8 +0,0 @@
-2008-12-09 Alexander Fehr <pizzapunk gmail com>
-
- * htop-0.8.1-1:
- New upstream release.
- New maintainer.
- Added patch to fix FS#12235.
- Enabled Unicode support.
- Added ChangeLog.
diff --git a/abs/extra-testing/htop/PKGBUILD b/abs/extra-testing/htop/PKGBUILD
deleted file mode 100644
index 95b9660..0000000
--- a/abs/extra-testing/htop/PKGBUILD
+++ /dev/null
@@ -1,22 +0,0 @@
-# $Id: PKGBUILD 21081 2008-12-09 17:41:11Z alexanderf $
-# Maintainer: Alexander Fehr <pizzapunk gmail com>
-
-pkgname=htop
-pkgver=0.8.3
-pkgrel=1
-pkgdesc="Interactive process viewer"
-arch=('i686' 'x86_64')
-url="http://htop.sourceforge.net/"
-license=('GPL')
-depends=('ncurses')
-options=('!emptydirs')
-source=(http://downloads.sourceforge.net/htop/htop-$pkgver.tar.gz)
-
-build() {
- cd "$srcdir/htop-$pkgver"
- sed -i 's|ncursesw/curses.h|curses.h|' RichString.h RichString.c || return 1
- ./configure --prefix=/usr --enable-unicode || return 1
- make || return 1
- make DESTDIR="$pkgdir" install || return 1
-}
-md5sums=('5c9f093f9eaddf6e77aa6d54c2116d0c')
diff --git a/abs/extra-testing/htop/htop-treeview.patch b/abs/extra-testing/htop/htop-treeview.patch
deleted file mode 100644
index bcf6334..0000000
--- a/abs/extra-testing/htop/htop-treeview.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur htop-0.8.1.orig/ProcessList.c htop-0.8.1/ProcessList.c
---- htop-0.8.1.orig/ProcessList.c 2008-09-23 08:23:14.000000000 +0200
-+++ htop-0.8.1/ProcessList.c 2008-12-09 15:14:56.000000000 +0100
-@@ -331,7 +331,7 @@
-
- for (int i = Vector_size(this->processes) - 1; i >= 0; i--) {
- Process* process = (Process*) (Vector_get(this->processes, i));
-- if (process->tgid == pid || (process->tgid == process->pid && process->ppid == pid)) {
-+ if (process->tgid == pid || process->ppid == pid) {
- Process* process = (Process*) (Vector_take(this->processes, i));
- Vector_add(children, process);
- }