summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/imdbpy/PKGBUILD
diff options
context:
space:
mode:
authorNathan Harris <nharris@eoimaging.com>2010-03-02 21:54:59 (GMT)
committerNathan Harris <nharris@eoimaging.com>2010-03-02 21:54:59 (GMT)
commitfbc9bf1fe2e307040254f8000e6c4d59580e06a0 (patch)
tree548db7dac734a40fd7e5ae4a5f743b73619cfc7e /abs/extra-testing/imdbpy/PKGBUILD
parente9a43217f3b09ae760644a9e8630bdfacea7472b (diff)
downloadlinhes_pkgbuild-fbc9bf1fe2e307040254f8000e6c4d59580e06a0.zip
linhes_pkgbuild-fbc9bf1fe2e307040254f8000e6c4d59580e06a0.tar.gz
linhes_pkgbuild-fbc9bf1fe2e307040254f8000e6c4d59580e06a0.tar.bz2
imdbpy: added for Jamu
Diffstat (limited to 'abs/extra-testing/imdbpy/PKGBUILD')
-rw-r--r--abs/extra-testing/imdbpy/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/extra-testing/imdbpy/PKGBUILD b/abs/extra-testing/imdbpy/PKGBUILD
new file mode 100644
index 0000000..4b84e8e
--- /dev/null
+++ b/abs/extra-testing/imdbpy/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 5794 2009-11-19 01:18:33Z andrea $
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Geoffroy Carrier <geoffroy.carrier@koon.fr>
+# Contributor: lang2 <wenzhi.liang@gmail.com>
+
+pkgname=imdbpy
+pkgver=4.3
+pkgrel=1
+pkgdesc="Python bindings for imdb"
+url="http://imdbpy.sourceforge.net/"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('python')
+makedepends=('setuptools')
+optdepends=('python-lxml' 'python-sqlalchemy' 'python-sqlobject')
+source=(http://downloads.sourceforge.net/$pkgname/IMDbPY-$pkgver.tar.gz)
+md5sums=('faf32115d861dc8a8de6b584dceb488d')
+
+build(){
+ cd "$srcdir/IMDbPY-$pkgver"
+ python setup.py install --root="$pkgdir" || return 1
+
+ # fix directories path
+ mv ${pkgdir}/usr/etc ${pkgdir}
+ install -d ${pkgdir}/usr/share
+ mv ${pkgdir}/usr/imdb ${pkgdir}/usr/share
+ mv ${pkgdir}/usr/doc ${pkgdir}/usr/share/imdb/
+}