summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/libgda
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-05-02 08:55:02 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-05-02 08:55:02 (GMT)
commit25e39d3ad6f66fad48c0183dd568e2fbfded5ca2 (patch)
tree0d8bb2c9bca3a20c3ac2067ff7453c0aae5e8a3e /abs/extra-testing/libgda
parent1f70585d4abb80a2cc47316ab2b4851637939997 (diff)
downloadlinhes_pkgbuild-25e39d3ad6f66fad48c0183dd568e2fbfded5ca2.zip
linhes_pkgbuild-25e39d3ad6f66fad48c0183dd568e2fbfded5ca2.tar.gz
linhes_pkgbuild-25e39d3ad6f66fad48c0183dd568e2fbfded5ca2.tar.bz2
Latest version or newly required deps for various packages.
Diffstat (limited to 'abs/extra-testing/libgda')
-rw-r--r--abs/extra-testing/libgda/PKGBUILD24
-rw-r--r--abs/extra-testing/libgda/bdb43.patch18
-rw-r--r--abs/extra-testing/libgda/libgda.install16
3 files changed, 58 insertions, 0 deletions
diff --git a/abs/extra-testing/libgda/PKGBUILD b/abs/extra-testing/libgda/PKGBUILD
new file mode 100644
index 0000000..7ecbd20
--- /dev/null
+++ b/abs/extra-testing/libgda/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 36066 2009-04-19 20:31:09Z jgc $
+# Maintainer: tobias <tobias@archlinux.org>
+# Contributor: Tobias Kieslich <tobias@justdreams.de>
+
+pkgname=libgda
+pkgver=4.0.2
+pkgrel=1
+pkgdesc="data abstraction layer; with mysql, pgsql, ldap, xml, sqlite providers"
+arch=(i686 x86_64)
+license=('GPL')
+depends=('glib2>=2.20.1' 'libxslt' 'db>=4.7' 'ncurses>=5.7-2' 'libsoup>=2.26.1'
+ 'libmysqlclient>=5.1.32-2' 'postgresql-libs>=8.3.7' 'libldap>=2.3.43-3' 'unixodbc' 'sqlite3>=3.6.13')
+makedepends=('intltool' 'pkgconfig' 'openjdk6')
+options=('!libtool')
+url="http://www.gnome-db.org"
+source=(http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/4.0/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('cd79f6542cdd9477017b76b5f81c776f')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --sysconfdir=/etc --disable-static || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+}
diff --git a/abs/extra-testing/libgda/bdb43.patch b/abs/extra-testing/libgda/bdb43.patch
new file mode 100644
index 0000000..3fe6e93
--- /dev/null
+++ b/abs/extra-testing/libgda/bdb43.patch
@@ -0,0 +1,18 @@
+diff -r -u libgda-1.2.0.old/providers/bdb/gda-bdb-recordset.c libgda-1.2.0/providers/bdb/gda-bdb-recordset.c
+--- libgda-1.2.0.old/providers/bdb/gda-bdb-recordset.c 2003-12-17 11:27:02.000000000 +0000
++++ libgda-1.2.0/providers/bdb/gda-bdb-recordset.c 2005-02-19 15:43:12.000000000 +0000
+@@ -227,10 +227,14 @@
+
+ /* get the number of records in the database */
+ ret = dbp->stat (dbp,
++#if BDB_VERSION > 40300
++ NULL,
++#endif
+ &statp,
+ #if BDB_VERSION < 40000
+ NULL,
+ #endif
++
+ 0);
+ if (ret != 0) {
+ gda_connection_add_error (cnc, gda_bdb_make_error (ret));
diff --git a/abs/extra-testing/libgda/libgda.install b/abs/extra-testing/libgda/libgda.install
new file mode 100644
index 0000000..6420004
--- /dev/null
+++ b/abs/extra-testing/libgda/libgda.install
@@ -0,0 +1,16 @@
+post_install() {
+ scrollkeeper-update -q -p var/lib/scrollkeeper
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*