summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/libjpeg/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-03-22 19:20:07 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-03-22 19:20:07 (GMT)
commitb7e8a22add9ff7e7ca41fe8c5fc25ea501eb3e2d (patch)
treefba15f03bf498dc1da24d9017e8c35df920e0eec /abs/extra-testing/libjpeg/PKGBUILD
parent50a39a9338fbddb79f581fdc52ee5e398054c6e7 (diff)
downloadlinhes_pkgbuild-b7e8a22add9ff7e7ca41fe8c5fc25ea501eb3e2d.zip
linhes_pkgbuild-b7e8a22add9ff7e7ca41fe8c5fc25ea501eb3e2d.tar.gz
linhes_pkgbuild-b7e8a22add9ff7e7ca41fe8c5fc25ea501eb3e2d.tar.bz2
Bring XBMC to LinHES.
Diffstat (limited to 'abs/extra-testing/libjpeg/PKGBUILD')
-rw-r--r--abs/extra-testing/libjpeg/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/extra-testing/libjpeg/PKGBUILD b/abs/extra-testing/libjpeg/PKGBUILD
new file mode 100644
index 0000000..996ae6c
--- /dev/null
+++ b/abs/extra-testing/libjpeg/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 19605 2008-11-28 10:52:08Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Committer: Judd Vinet <jvinet@zeroflux.org>
+
+pkgname=libjpeg
+pkgver=6b
+pkgrel=6
+pkgdesc="Library of JPEG support functions"
+arch=('i686' 'x86_64')
+url="http://www.ijg.org/"
+license=('custom')
+depends=('glibc')
+makedepends=('libtool')
+options=(!libtool)
+source=(ftp://ftp.uu.net/graphics/jpeg/jpegsrc.v$pkgver.tar.gz)
+md5sums=('dbd5f3b47ed13132f04c685d608a7547')
+
+build() {
+ cd $srcdir/jpeg-$pkgver
+ cp /usr/share/libtool/config/config.{guess,sub} .
+ sed -i "s#./libtool#libtool#" configure
+ ./configure --prefix=/usr --enable-shared --enable-static
+ make || return 1
+ mkdir -p $pkgdir/usr/{bin,lib,include,share/man/man1}
+ make prefix=$pkgdir/usr mandir=$pkgdir/usr/share/man/man1 install
+ install -m644 jpegint.h $pkgdir/usr/include
+ install -Dm644 README $pkgdir/usr/share/licenses/libjpeg/README
+}