summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/libvisual-plugins/60_no-const-vispluginfo-in-nastyfft.patch
diff options
context:
space:
mode:
authorBob Igo <bob@stormlogic.com>2009-02-03 16:03:11 (GMT)
committerBob Igo <bob@stormlogic.com>2009-02-03 16:03:11 (GMT)
commitc27e26468ce03250538718dce451fdc4598bd715 (patch)
tree56ec8d7216fab091e4c4133345af79163cf3f0ad /abs/extra-testing/libvisual-plugins/60_no-const-vispluginfo-in-nastyfft.patch
parent1a8433a3240525038ae750b90c358ecbe15882c2 (diff)
parent9cba95f8fe4c9a606db81a4da2d229cfd3a7b68c (diff)
downloadlinhes_pkgbuild-c27e26468ce03250538718dce451fdc4598bd715.zip
linhes_pkgbuild-c27e26468ce03250538718dce451fdc4598bd715.tar.gz
linhes_pkgbuild-c27e26468ce03250538718dce451fdc4598bd715.tar.bz2
Merge branch 'master' of ssh://igo@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/libvisual-plugins/60_no-const-vispluginfo-in-nastyfft.patch')
-rw-r--r--abs/extra-testing/libvisual-plugins/60_no-const-vispluginfo-in-nastyfft.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/abs/extra-testing/libvisual-plugins/60_no-const-vispluginfo-in-nastyfft.patch b/abs/extra-testing/libvisual-plugins/60_no-const-vispluginfo-in-nastyfft.patch
new file mode 100644
index 0000000..8e54e02
--- /dev/null
+++ b/abs/extra-testing/libvisual-plugins/60_no-const-vispluginfo-in-nastyfft.patch
@@ -0,0 +1,18 @@
+The static VisPluginInfo in nastyfft was declared as const, but libvisual write
+to its refcount when it visual_object_unref()s it (nasty!). This is broken at
+various levels: libvisual shouldn't be writing to this static plugin which is
+allocated by a dlopen()ed plugin, and it should also honor the "const
+VisPluginInfo" API... Anyway, nastyfft was the only occurrence and this fixes
+the crash for now; LP: #287448.
+
+--- libvisual-plugins-0.4.0.dfsg.1.orig/plugins/actor/nastyfft/actor_nastyfft.c
++++ libvisual-plugins-0.4.0.dfsg.1/plugins/actor/nastyfft/actor_nastyfft.c
+@@ -80,7 +80,7 @@
+ .vidoptions.depth = VISUAL_VIDEO_DEPTH_GL
+ }};
+
+- static const VisPluginInfo info[] = {{
++ static VisPluginInfo info[] = {{
+ .type = VISUAL_PLUGIN_TYPE_ACTOR,
+
+ .plugname = N_("nastyfft"),