summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/miro
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-03 07:56:23 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-03 07:56:23 (GMT)
commit0ce6326882d1ef6b45955ce0af948aa3da22bc07 (patch)
tree6ef646f87190a95deea7641df53c6ee5396c900c /abs/extra-testing/miro
parent907606040ebd98338b939452ee37698b62718820 (diff)
downloadlinhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.zip
linhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.tar.gz
linhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.tar.bz2
Added support for Miro.
Diffstat (limited to 'abs/extra-testing/miro')
-rw-r--r--abs/extra-testing/miro/ChangeLog34
-rw-r--r--abs/extra-testing/miro/Miro-xulrunner.patch64
-rw-r--r--abs/extra-testing/miro/PKGBUILD41
-rw-r--r--abs/extra-testing/miro/boost_1.36.0_fix.patch32
-rw-r--r--abs/extra-testing/miro/miro.install17
-rw-r--r--abs/extra-testing/miro/miro_python26.patch16
-rw-r--r--abs/extra-testing/miro/missing-headers.patch33
7 files changed, 237 insertions, 0 deletions
diff --git a/abs/extra-testing/miro/ChangeLog b/abs/extra-testing/miro/ChangeLog
new file mode 100644
index 0000000..223b1de
--- /dev/null
+++ b/abs/extra-testing/miro/ChangeLog
@@ -0,0 +1,34 @@
+2008-01-30 Eric Belanger <eric@archlinux.org>
+ * miro-1.1-2
+ * rebuilt against xulrunner 1.8.1.11
+
+2008-01-16 Varun Acharya <varun@archlinux.org>
+
+ * upgpkg miro-1.1
+
+2008-01-03 Varun Acharya <varun@archlinux.org>
+
+ * Adopted and moved to extra, miro-1.0-2
+
+2007-11-26 Alessio 'mOLOk' Bolognino <themolok@gmail.com>
+
+ * miro-1.0-2
+ * changed url
+ * added sqlite3 as dep (fix FS#8636)
+
+2007-11-13 Alessio 'mOLOk' Bolognino <themolok@gmail.com>
+
+ * miro-1.0-1
+ * version bump
+
+2007-09-09 Alessio 'mOLOk' Bolognino <themolok@gmail.com>
+
+ * miro-0.9.9-1
+ * version bump
+
+2007-08-08 Alessio 'mOLOk' Bolognino <themolok@gmail.com>
+
+ * miro-0.9.8.1-1
+ * initial commit
+
+
diff --git a/abs/extra-testing/miro/Miro-xulrunner.patch b/abs/extra-testing/miro/Miro-xulrunner.patch
new file mode 100644
index 0000000..b8f4db3
--- /dev/null
+++ b/abs/extra-testing/miro/Miro-xulrunner.patch
@@ -0,0 +1,64 @@
+diff -up Miro-1.2.3/platform/gtk-x11/platform/mozsetup.py.old Miro-1.2.3/platform/gtk-x11/platform/mozsetup.py
+--- Miro-1.2.3/platform/gtk-x11/platform/mozsetup.py.old 2008-04-22 17:17:01.000000000 +0200
++++ Miro-1.2.3/platform/gtk-x11/platform/mozsetup.py 2008-04-28 12:51:46.000000000 +0200
+@@ -106,8 +106,8 @@ def setupMozillaEnvironment():
+ set_profile_path = gtkmozembed.gtk_moz_embed_set_profile_path
+
+ set_profile_path(config.get(prefs.SUPPORT_DIRECTORY), 'mozilla')
+- if hasattr(gtkmozembed, 'set_comp_path'):
+- set_comp_path = gtkmozembed.set_comp_path
++ if hasattr(gtkmozembed, 'set_path'):
++ set_comp_path = gtkmozembed.set_path
+ elif hasattr(gtkmozembed, 'set_path'):
+ set_comp_path = gtkmozembed.set_path
+ else:
+diff -up Miro-1.2.3/platform/gtk-x11/setup.py.old Miro-1.2.3/platform/gtk-x11/setup.py
+--- Miro-1.2.3/platform/gtk-x11/setup.py.old 2008-04-22 17:17:01.000000000 +0200
++++ Miro-1.2.3/platform/gtk-x11/setup.py 2008-04-28 13:14:27.000000000 +0200
+@@ -209,6 +209,7 @@ def parsePkgConfig(command, components,
+ options_dict = {
+ 'include_dirs' : [],
+ 'library_dirs' : [],
++ 'runtime_dirs' : [],
+ 'libraries' : [],
+ 'extra_compile_args' : []
+ }
+@@ -224,6 +225,11 @@ def parsePkgConfig(command, components,
+ options_dict['libraries'].append(rest)
+ else:
+ options_dict['extra_compile_args'].append(comp)
++
++ commandLine = "%s --variable=libdir %s" % (command, components)
++ output = getCommandOutput(commandLine).strip()
++ options_dict['runtime_dirs'].append(output)
++
+ return options_dict
+
+ #### The fasttypes extension ####
+@@ -279,6 +285,8 @@ mozilla_browser_options = parsePkgConfig
+ "gtk+-2.0 glib-2.0 pygtk-2.0 --define-variable=includetype=unstable %s %s" % (gtkmozembed, xpcom))
+ mozilla_lib_path = parsePkgConfig('pkg-config',
+ '%s' % gtkmozembed)['library_dirs']
++runtime_lib_path = parsePkgConfig('pkg-config',
++ '%s' % gtkmozembed)['runtime_dirs']
+ # Find the base mozilla directory, and add the subdirs we need.
+ def allInDir(directory, subdirs):
+ for subdir in subdirs:
+@@ -334,7 +342,7 @@ mozilla_browser_ext = Extension("miro.pl
+ os.path.join(platform_html_frontend_dir,'DragAndDrop.cc'),
+ os.path.join(platform_html_frontend_dir,'XPCOMUtil.cc'),
+ ],
+- runtime_library_dirs=mozilla_lib_path,
++ runtime_library_dirs=runtime_lib_path,
+ **mozilla_browser_options)
+ #### Xlib Extension ####
+ xlib_ext = \
+@@ -434,7 +442,7 @@ class install_data (distutils.command.in
+ BUILD_MACHINE="%s@%s" % (getlogin(),
+ os.uname()[1]),
+ BUILD_TIME=str(time.time()),
+- MOZILLA_LIB_PATH=mozilla_lib_path[0])
++ MOZILLA_LIB_PATH=runtime_lib_path[0])
+ self.outfiles.append(dest)
+
+ locale_dir = os.path.join (resource_dir, "locale")
diff --git a/abs/extra-testing/miro/PKGBUILD b/abs/extra-testing/miro/PKGBUILD
new file mode 100644
index 0000000..efc44b3
--- /dev/null
+++ b/abs/extra-testing/miro/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id: PKGBUILD 18952 2008-11-12 08:23:26Z ronald $
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+
+pkgname=miro
+pkgver=1.2.8
+pkgrel=2
+pkgdesc="The free and open source internet TV platform"
+arch=('i686' 'x86_64')
+url="http://www.getmiro.com"
+license=('GPL2')
+depends=('xine-lib>=1.1.12' 'boost>=1.36.0' 'gnome-python-extras>=2.19.1'
+ 'dbus-python>=0.82.4' 'pyrex' 'xulrunner>=1.9.0.1' 'gtk2' 'nspr')
+makedepends=('pkgconfig' 'qt3')
+install=miro.install
+conflicts=('democracy')
+replaces=('democracy')
+provides=('democracy')
+
+source=(http://ftp.osuosl.org/pub/pculture.org/miro/src/Miro-${pkgver}.tar.gz
+ missing-headers.patch
+ Miro-xulrunner.patch
+ boost_1.36.0_fix.patch
+ miro_python26.patch)
+
+md5sums=('b468a953014272095171303ba3f0745d'
+ 'b5482eac565a26817af0105b061a8ad5'
+ '3c06b40cd13c2fb202f58dcf64d4b524'
+ '3b4e1eac01155b9de381b0744ba9d725'
+ 'a913b2340136ac0fbb9034523faf667a')
+
+build() {
+ cd ${srcdir}/Miro-${pkgver}
+ patch -Np1 -i ${srcdir}/missing-headers.patch || return 1
+ patch -Np1 -i ${srcdir}/Miro-xulrunner.patch || return 1
+ patch -Np1 -i ${srcdir}/boost_1.36.0_fix.patch || return 1
+
+ cd platform/gtk-x11
+ patch -Np0 -i ${srcdir}/miro_python26.patch || return 1
+
+ python setup.py install --root=${pkgdir} || return 1
+}
diff --git a/abs/extra-testing/miro/boost_1.36.0_fix.patch b/abs/extra-testing/miro/boost_1.36.0_fix.patch
new file mode 100644
index 0000000..b3b5a48
--- /dev/null
+++ b/abs/extra-testing/miro/boost_1.36.0_fix.patch
@@ -0,0 +1,32 @@
+--- Miro-1.2.7/portable/libtorrent/src/torrent_info.cpp.old 2008-09-21 13:47:00.122974031 +0200
++++ Miro-1.2.7/portable/libtorrent/src/torrent_info.cpp 2008-09-21 13:48:54.812965713 +0200
+@@ -352,7 +352,7 @@
+ fs::path tmp = m_name;
+ if (tmp.is_complete()) throw std::runtime_error("torrent contains "
+ "a file with an absolute path: '" + m_name + "'");
+- if (tmp.has_branch_path()) throw std::runtime_error(
++ if (!tmp.branch_path().empty()) throw std::runtime_error(
+ "torrent contains name with directories: '" + m_name + "'");
+
+ // extract file list
+@@ -556,7 +556,7 @@
+ {
+ // TORRENT_ASSERT(file.begin() != file.end());
+
+- if (!file.has_branch_path())
++ if (file.branch_path().empty())
+ {
+ // you have already added at least one file with a
+ // path to the file (branch_path), which means that
+
+--- Miro-1.2.7/portable/libtorrent/include/libtorrent/disk_io_thread.hpp.old 2008-09-21 13:57:05.433330334 +0200
++++ Miro-1.2.7/portable/libtorrent/include/libtorrent/disk_io_thread.hpp 2008-09-21 13:57:29.060304305 +0200
+@@ -41,6 +41,7 @@
+ #include <boost/bind.hpp>
+ #include <boost/pool/pool.hpp>
+ #include <boost/noncopyable.hpp>
++#include <boost/thread/condition.hpp>
+ #include "libtorrent/config.hpp"
+
+ namespace libtorrent
+
diff --git a/abs/extra-testing/miro/miro.install b/abs/extra-testing/miro/miro.install
new file mode 100644
index 0000000..f37f11d
--- /dev/null
+++ b/abs/extra-testing/miro/miro.install
@@ -0,0 +1,17 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ update-desktop-database -q
+}
+
+op=$1
+shift
+
+$op $*
+
diff --git a/abs/extra-testing/miro/miro_python26.patch b/abs/extra-testing/miro/miro_python26.patch
new file mode 100644
index 0000000..f404a4e
--- /dev/null
+++ b/abs/extra-testing/miro/miro_python26.patch
@@ -0,0 +1,16 @@
+--- miro.real 2008-10-24 19:49:17.000000000 +0200
++++ miro.real.new 2008-11-12 08:51:17.649458321 +0100
+@@ -6,8 +6,12 @@
+ if xlibhelper.XInitThreads() == 0:
+ print "WARNING: XInitThreads() failed!"
+
+-import os.path
++import miro.feedparser
++import miro.storedatabase
+ import sys
++sys.modules['feedparser'] = miro.feedparser
++sys.modules['storedatabase'] = miro.storedatabase
++import os.path
+ import optparse
+
+ import pygtk
diff --git a/abs/extra-testing/miro/missing-headers.patch b/abs/extra-testing/miro/missing-headers.patch
new file mode 100644
index 0000000..7dc42b8
--- /dev/null
+++ b/abs/extra-testing/miro/missing-headers.patch
@@ -0,0 +1,33 @@
+diff -ur a/portable/libtorrent/include/libtorrent/peer_id.hpp b/portable/libtorrent/include/libtorrent/peer_id.hpp
+--- a/portable/libtorrent/include/libtorrent/peer_id.hpp 2008-04-22 10:17:04.000000000 -0500
++++ b/portable/libtorrent/include/libtorrent/peer_id.hpp 2008-05-07 01:51:09.000000000 -0500
+@@ -38,6 +38,7 @@
+ #include <cctype>
+ #include <algorithm>
+ #include <string>
++#include <cstring>
+
+ #include "libtorrent/config.hpp"
+ #include "libtorrent/assert.hpp"
+diff -ur a/portable/libtorrent/src/entry.cpp b/portable/libtorrent/src/entry.cpp
+--- a/portable/libtorrent/src/entry.cpp 2008-04-22 10:17:04.000000000 -0500
++++ b/portable/libtorrent/src/entry.cpp 2008-05-07 02:16:14.000000000 -0500
+@@ -33,6 +33,7 @@
+ #include "libtorrent/pch.hpp"
+
+ #include <algorithm>
++#include <iostream>
+ #include <iomanip>
+ #include "libtorrent/entry.hpp"
+ #include "libtorrent/config.hpp"
+diff -ur a/portable/libtorrent/src/file.cpp b/portable/libtorrent/src/file.cpp
+--- a/portable/libtorrent/src/file.cpp 2008-04-22 10:17:04.000000000 -0500
++++ b/portable/libtorrent/src/file.cpp 2008-05-07 01:53:04.000000000 -0500
+@@ -68,6 +68,7 @@
+ #include <boost/filesystem/operations.hpp>
+ #include "libtorrent/file.hpp"
+ #include <sstream>
++#include <cstring>
+
+ #ifndef O_BINARY
+ #define O_BINARY 0