summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/mjpegtools/mjpegtools-1.8.0-limits.h.patch
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-01-12 19:19:50 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-01-12 19:19:50 (GMT)
commit6c619a60fd89b5e75a93cff06977c552ddf1e621 (patch)
tree630ca50ea1c128c4be85ce920ecf034c561bf7fe /abs/extra-testing/mjpegtools/mjpegtools-1.8.0-limits.h.patch
parent0b2b9b97e95f8f8bfda1d1fe09136d121cd0750d (diff)
parent634dff8fdd0a9c866c92f0020f282c23d1a438d8 (diff)
downloadlinhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.zip
linhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.tar.gz
linhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Conflicts: abs/core-testing/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/extra-testing/mjpegtools/mjpegtools-1.8.0-limits.h.patch')
-rw-r--r--abs/extra-testing/mjpegtools/mjpegtools-1.8.0-limits.h.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/extra-testing/mjpegtools/mjpegtools-1.8.0-limits.h.patch b/abs/extra-testing/mjpegtools/mjpegtools-1.8.0-limits.h.patch
new file mode 100644
index 0000000..41a59ca
--- /dev/null
+++ b/abs/extra-testing/mjpegtools/mjpegtools-1.8.0-limits.h.patch
@@ -0,0 +1,30 @@
+--- mjpegtools-1.8.0.orig/mpeg2enc/macroblock.cc 2007-11-29 19:45:06 +0000
++++ mjpegtools-1.8.0.orig/mpeg2enc/macroblock.cc 2007-11-29 19:45:33 +0000
+@@ -20,6 +20,7 @@
+ */
+
+ #include <stdio.h>
++#include <limits.h>
+
+ #include "macroblock.hh"
+ #include "mpeg2syntaxcodes.h"
+--- mjpegtools-1.8.0.orig/mpeg2enc/picturereader.cc 2007-11-29 19:45:06 +0000
++++ mjpegtools-1.8.0.orig/mpeg2enc/picturereader.cc 2007-11-29 19:45:52 +0000
+@@ -26,6 +26,7 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <errno.h>
++#include <limits.h>
+ #include "simd.h"
+ #include "mpeg2encoder.hh"
+
+--- mjpegtools-1.8.0.orig/mplex/inputstrm.cpp 2007-11-29 19:45:06 +0000
++++ mjpegtools-1.8.0.orig/mplex/inputstrm.cpp 2007-11-29 19:46:15 +0000
+@@ -23,6 +23,7 @@
+
+ #include <config.h>
+ #include <assert.h>
++#include <limits.h>
+
+ #include "mjpeg_types.h"
+ #include "inputstrm.hpp"