summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/mjpegtools
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-08 17:08:28 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-08 17:08:28 (GMT)
commitc38715641e214272ad7dc6d495edd29940366e7f (patch)
tree9dcd507543e67458d98fa7462f62026041524047 /abs/extra-testing/mjpegtools
parent3d91b06198a56b6579cb0bd77de65f5908571b87 (diff)
downloadlinhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.zip
linhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.tar.gz
linhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.tar.bz2
packages that will be needed in the future.
This is the initial merge of packages from MythVantage that are not MythVantage specific.
Diffstat (limited to 'abs/extra-testing/mjpegtools')
-rw-r--r--abs/extra-testing/mjpegtools/PKGBUILD27
-rw-r--r--abs/extra-testing/mjpegtools/mjpegtools-1.8.0-gcc41.patch12
-rw-r--r--abs/extra-testing/mjpegtools/mjpegtools-1.8.0-libc.patch142
3 files changed, 181 insertions, 0 deletions
diff --git a/abs/extra-testing/mjpegtools/PKGBUILD b/abs/extra-testing/mjpegtools/PKGBUILD
new file mode 100644
index 0000000..663e839
--- /dev/null
+++ b/abs/extra-testing/mjpegtools/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=mjpegtools
+pkgver=1.8.0
+pkgrel=1
+pkgdesc="The mjpeg programs are a set of tools that can do recording of videos and playback, simple cut-and-paste editing and the MPEG compression of audio and video under Linux. "
+arch=(i686 x86_64)
+license=('GPL')
+url="http://mjpeg.sourceforge.net/"
+depends=('libjpeg' 'libpng' 'sdl' 'gcc' 'libdv')
+makedepends=('gtk2')
+options=('!makeflags' '!libtool')
+source=(http://downloads.sourceforge.net/sourceforge/mjpeg/${pkgname}-${pkgver}.tar.gz
+ mjpegtools-1.8.0-gcc41.patch mjpegtools-1.8.0-libc.patch)
+#md5sums=('6fd98362310480bdaf7171e9659f165f' '803eccd889c60a442ee23ba65951fadc')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+# patch -Np1 -i ${startdir}/src/mjpegtools-1.8.0-gcc41.patch || return 1
+ patch -Np1 -i ${startdir}/src/mjpegtools-1.8.0-libc.patch || return 1
+ ./configure --prefix=/usr
+ find -name Makefile -exec sed -i -e 's:-march=k8 -mtune=k8::' -e 's:-march=pentium3 -mtune=pentium3::' {} \;
+
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+
+ install -m644 mpeg2enc/mpeg2syntaxcodes.h \
+ ${startdir}/pkg/usr/include/mjpegtools/mpeg2enc/
+}
diff --git a/abs/extra-testing/mjpegtools/mjpegtools-1.8.0-gcc41.patch b/abs/extra-testing/mjpegtools/mjpegtools-1.8.0-gcc41.patch
new file mode 100644
index 0000000..77d556f
--- /dev/null
+++ b/abs/extra-testing/mjpegtools/mjpegtools-1.8.0-gcc41.patch
@@ -0,0 +1,12 @@
+diff -ur mjpegtools-1.8.0-orig/y4mdenoise/Region2D.hh mjpegtools-1.8.0/y4mdenoise/Region2D.hh
+--- mjpegtools-1.8.0-orig/y4mdenoise/Region2D.hh 2005-12-19 12:36:54.000000000 +0300
++++ mjpegtools-1.8.0/y4mdenoise/Region2D.hh 2005-12-19 12:44:36.000000000 +0300
+@@ -16,7 +16,7 @@
+
+ #include "Status_t.h"
+ #include <iostream>
+-
++#include <cassert>
+
+
+ // The 2-dimensional region class. Parameterized by the numeric type
diff --git a/abs/extra-testing/mjpegtools/mjpegtools-1.8.0-libc.patch b/abs/extra-testing/mjpegtools/mjpegtools-1.8.0-libc.patch
new file mode 100644
index 0000000..6ea14e0
--- /dev/null
+++ b/abs/extra-testing/mjpegtools/mjpegtools-1.8.0-libc.patch
@@ -0,0 +1,142 @@
+diff -ur mjpegtools-1.8.0.old/mpeg2enc/encodertypes.h mjpegtools-1.8.0/mpeg2enc/encodertypes.h
+--- mjpegtools-1.8.0.old/mpeg2enc/encodertypes.h 2008-10-28 13:17:34.000000000 -0500
++++ mjpegtools-1.8.0/mpeg2enc/encodertypes.h 2008-10-28 13:34:41.000000000 -0500
+@@ -23,7 +23,9 @@
+ * 02111-1307, USA.
+ *
+ */
+-
++
++#include <cstdlib>
++
+ #include "config.h"
+
+
+diff -ur mjpegtools-1.8.0.old/mpeg2enc/macroblock.cc mjpegtools-1.8.0/mpeg2enc/macroblock.cc
+--- mjpegtools-1.8.0.old/mpeg2enc/macroblock.cc 2008-10-28 13:17:34.000000000 -0500
++++ mjpegtools-1.8.0/mpeg2enc/macroblock.cc 2008-10-28 13:32:54.000000000 -0500
+@@ -19,6 +19,9 @@
+ *
+ */
+
++
++#include <limits>
++
+ #include <stdio.h>
+
+ #include "macroblock.hh"
+@@ -49,7 +52,7 @@
+ {
+ vector<MotionEst>::iterator i;
+ vector<MotionEst>::iterator min_me;
+- int best_score = INT_MAX;
++ int best_score = std::numeric_limits<int>::max();
+ int cur_score;
+
+ //
+diff -ur mjpegtools-1.8.0.old/mpeg2enc/motionest.cc mjpegtools-1.8.0/mpeg2enc/motionest.cc
+--- mjpegtools-1.8.0.old/mpeg2enc/motionest.cc 2008-10-28 13:17:34.000000000 -0500
++++ mjpegtools-1.8.0/mpeg2enc/motionest.cc 2008-10-28 13:38:03.000000000 -0500
+@@ -45,6 +45,8 @@
+ *
+ */
+
++#include <limits>
++
+ #include <config.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+@@ -1643,7 +1645,7 @@
+ a basis for setting thresholds for rejecting really dud 4*4
+ and 2*2 sub-sampled matches.
+ */
+- best.weight = psad_00(reffld+i0+j0*lx,ssblk->mb,lx,h,INT_MAX);
++ best.weight = psad_00(reffld+i0+j0*lx,ssblk->mb,lx,h,std::numeric_limits<int>::max());
+ best.x = 0;
+ best.y = 0;
+
+@@ -1714,7 +1716,7 @@
+ /* Final polish: half-pel search of best 1*1 against
+ reconstructed image.
+ */
+- res->sad = INT_MAX;
++ res->sad = std::numeric_limits<int>::max();
+ x = (i0+best.x)<<1;
+ y = (j0+best.y)<<1;
+
+diff -ur mjpegtools-1.8.0.old/mpeg2enc/picturereader.cc mjpegtools-1.8.0/mpeg2enc/picturereader.cc
+--- mjpegtools-1.8.0.old/mpeg2enc/picturereader.cc 2008-10-28 13:17:34.000000000 -0500
++++ mjpegtools-1.8.0/mpeg2enc/picturereader.cc 2008-10-28 13:36:50.000000000 -0500
+@@ -20,6 +20,8 @@
+ */
+
+
++#include <limits>
++
+ #include "picturereader.hh"
+ #include <stdio.h>
+ #include <stdlib.h>
+@@ -37,7 +39,7 @@
+ frames_read = 0;
+ last_frame = -1;
+ lum_mean = 0;
+- istrm_nframes = INT_MAX;
++ istrm_nframes = std::numeric_limits<int>::max();
+ }
+
+
+diff -ur mjpegtools-1.8.0.old/mplex/inputstrm.cpp mjpegtools-1.8.0/mplex/inputstrm.cpp
+--- mjpegtools-1.8.0.old/mplex/inputstrm.cpp 2008-10-28 13:17:34.000000000 -0500
++++ mjpegtools-1.8.0/mplex/inputstrm.cpp 2008-10-28 13:56:15.000000000 -0500
+@@ -21,6 +21,8 @@
+ */
+
+
++#include <limits>
++
+ #include <config.h>
+ #include <assert.h>
+
+@@ -72,7 +74,7 @@
+ au(0),
+ muxinto( into ),
+ kind(_kind),
+- buffer_min(INT_MAX),
++ buffer_min(std::numeric_limits<int>::max()),
+ buffer_max(1)
+ {
+ }
+diff -ur mjpegtools-1.8.0.old/mplex/main.cpp mjpegtools-1.8.0/mplex/main.cpp
+--- mjpegtools-1.8.0.old/mplex/main.cpp 2008-10-28 13:17:34.000000000 -0500
++++ mjpegtools-1.8.0/mplex/main.cpp 2008-10-28 14:06:49.000000000 -0500
+@@ -26,6 +26,7 @@
+ *************************************************************************/
+
+ #include <config.h>
++#include <cstring>
+ #include <stdio.h>
+ #ifdef HAVE_GETOPT_H
+ #include <getopt.h>
+diff -ur mjpegtools-1.8.0.old/mplex/multiplexor.cpp mjpegtools-1.8.0/mplex/multiplexor.cpp
+--- mjpegtools-1.8.0.old/mplex/multiplexor.cpp 2008-10-28 13:17:34.000000000 -0500
++++ mjpegtools-1.8.0/mplex/multiplexor.cpp 2008-10-28 13:59:51.000000000 -0500
+@@ -19,6 +19,7 @@
+ */
+
+ #define STREAM_LOGGING
++#include <cstring>
+ #include <config.h>
+ #include <math.h>
+ #include <stdlib.h>
+diff -ur mjpegtools-1.8.0.old/mplex/padstrm.cpp mjpegtools-1.8.0/mplex/padstrm.cpp
+--- mjpegtools-1.8.0.old/mplex/padstrm.cpp 2008-10-28 13:17:34.000000000 -0500
++++ mjpegtools-1.8.0/mplex/padstrm.cpp 2008-10-28 14:03:24.000000000 -0500
+@@ -20,6 +20,8 @@
+ */
+
+
++#include <cstring>
++
+ #ifdef HAVE_CONFIG_H
+ #include "config.h"
+ #endif