summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/mplayer
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-11 18:41:04 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-11 18:41:04 (GMT)
commitbcf5ec3fa5da5bbac9a1eaba782bbcea0278d9b7 (patch)
tree1db739b5689e79de25ff05521ff1ef620478df50 /abs/extra-testing/mplayer
parent22cb9c31cde8a125c3b7d159d8b50941cb5c7714 (diff)
downloadlinhes_pkgbuild-bcf5ec3fa5da5bbac9a1eaba782bbcea0278d9b7.zip
linhes_pkgbuild-bcf5ec3fa5da5bbac9a1eaba782bbcea0278d9b7.tar.gz
linhes_pkgbuild-bcf5ec3fa5da5bbac9a1eaba782bbcea0278d9b7.tar.bz2
Updated various packages.
Diffstat (limited to 'abs/extra-testing/mplayer')
-rw-r--r--abs/extra-testing/mplayer/PKGBUILD42
-rw-r--r--abs/extra-testing/mplayer/demux_audio_fix_20080129.diff11
-rw-r--r--abs/extra-testing/mplayer/demux_mov_fix_20080129.diff45
-rw-r--r--abs/extra-testing/mplayer/mplayer_desktop.patch11
-rw-r--r--abs/extra-testing/mplayer/stream_cddb_fix_20080120.diff32
-rw-r--r--abs/extra-testing/mplayer/url_fix_20080120.diff10
6 files changed, 32 insertions, 119 deletions
diff --git a/abs/extra-testing/mplayer/PKGBUILD b/abs/extra-testing/mplayer/PKGBUILD
index 43dad94..c1fdb7c 100644
--- a/abs/extra-testing/mplayer/PKGBUILD
+++ b/abs/extra-testing/mplayer/PKGBUILD
@@ -1,14 +1,14 @@
-# $Id: PKGBUILD 3632 2008-06-26 11:48:49Z paul $
+# $Id: PKGBUILD 20619 2008-12-06 02:41:24Z allan $
# Maintainer: Thomas Bächler <thomas@archlinux.org>
pkgname=mplayer
pkgver=1.0rc2
-pkgrel=6
+pkgrel=9
pkgdesc="A movie player for linux"
arch=(i686 x86_64)
depends=('libxxf86dga' 'libxv' 'libmad' 'giflib' 'cdparanoia' 'gtk2'
- 'sdl' 'lame' 'libtheora' 'xvidcore'
+ 'sdl' 'lame' 'libtheora' 'xvidcore' 'zlib'
'libgl' 'smbclient' 'aalib' 'jack-audio-connection-kit'
- 'x264>=20080625' 'faac' 'lirc-utils' 'ttf-dejavu')
+ 'x264>=20080625' 'faac' 'lirc-utils' 'ttf-dejavu' 'fribidi')
license=('GPL')
url="http://www.mplayerhq.hu/"
makedepends=('libcaca' 'unzip' 'live-media' 'libdca' 'mesa')
@@ -19,17 +19,14 @@ source=(http://www.mplayerhq.hu/MPlayer/releases/MPlayer-${pkgver}.tar.bz2
http://www.mplayerhq.hu/MPlayer/patches/demux_mov_fix_20080129.diff
http://www.mplayerhq.hu/MPlayer/patches/url_fix_20080120.diff
http://www.mplayerhq.hu/MPlayer/patches/stream_cddb_fix_20080120.diff
- ivtv_2.6.24.patch)
-md5sums=('7e27e535c2d267637df34898f1b91707'
- 'e4e2020d11b681aac898103b3ba723c4'
- '320af7daa1b248ee8e8c15d34d7923e3'
- 'ce999929155f509a3e6bee41d9d613ed'
- '6a2c124586e1e6c44ae4ca1b4be9b6e4'
- 'c7d1bcdd61fcceb7598d61fe2213c587'
- '1ef35068587f6b6dbc99342567895236')
+ ivtv_2.6.24.patch mplayer_desktop.patch)
+md5sums=('7e27e535c2d267637df34898f1b91707' 'e4e2020d11b681aac898103b3ba723c4'\
+ '320af7daa1b248ee8e8c15d34d7923e3' 'ce999929155f509a3e6bee41d9d613ed'\
+ '6a2c124586e1e6c44ae4ca1b4be9b6e4' 'c7d1bcdd61fcceb7598d61fe2213c587'\
+ '1ef35068587f6b6dbc99342567895236' '4c49195a4a1702f0cb321abdc3c07741')
build() {
- cd $startdir/src/MPlayer-${pkgver}
+ cd ${srcdir}/MPlayer-${pkgver}
# Custom CFLAGS break the mplayer build
unset CFLAGS
@@ -39,19 +36,22 @@ build() {
# Workaround for changed ivtv interface since it went mainline in 2.6.24
patch -p1 -i ../ivtv_2.6.24.patch || return 1
-
+
+ # mplayer.desktop fix
+ patch -p1 -i ../mplayer_desktop.patch || return 1
+
# Fix security issues
for p in demux_audio_fix_20080129.diff demux_mov_fix_20080129.diff url_fix_20080120.diff stream_cddb_fix_20080120.diff; do
patch -p0 -i ../${p}
done
- cd $startdir/src/MPlayer-${pkgver}
+ cd ${srcdir}/MPlayer-${pkgver}
./configure --prefix=/usr --enable-gui --disable-arts --enable-x11 \
--enable-runtime-cpudetection --confdir=/etc/mplayer --disable-nas \
--enable-gl --enable-tv-v4l1 --enable-tv-v4l2 --enable-largefiles \
--disable-liblzo --disable-speex --disable-openal \
- --disable-fribidi --disable-libdv --disable-musepack \
+ --enable-fribidi --disable-libdv --disable-musepack \
--language=all --disable-dvdnav --disable-esd --disable-mga \
--disable-libamr_nb \
--with-extraincdir=/usr/lib/live-media
@@ -59,9 +59,9 @@ build() {
[ "$CARCH" = "i686" ] && sed 's|-march=i486|-march=i686|g' -i config.mak
make || return 1
- make -j1 DESTDIR=${startdir}/pkg install
- cp etc/{codecs.conf,input.conf,example.conf} ${startdir}/pkg/etc/mplayer/
- ln -s /usr/share/fonts/TTF/DejaVuSans.ttf ${startdir}/pkg/usr/share/mplayer/subfont.ttf
- rm -rf ${startdir}/pkg/usr/share/mplayer/font
- mv ${startdir}/src/Blue ${startdir}/pkg/usr/share/mplayer/skins/default
+ make -j1 DESTDIR=${pkgdir} install
+ cp etc/{codecs.conf,input.conf,example.conf} ${pkgdir}/etc/mplayer/
+ ln -s /usr/share/fonts/TTF/DejaVuSans.ttf ${pkgdir}/usr/share/mplayer/subfont.ttf
+ rm -rf ${pkgdir}/usr/share/mplayer/font
+ mv ${srcdir}/Blue ${pkgdir}/usr/share/mplayer/skins/default
}
diff --git a/abs/extra-testing/mplayer/demux_audio_fix_20080129.diff b/abs/extra-testing/mplayer/demux_audio_fix_20080129.diff
deleted file mode 100644
index 1b18b6e..0000000
--- a/abs/extra-testing/mplayer/demux_audio_fix_20080129.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- libmpdemux/demux_audio.c (revision 24724)
-+++ libmpdemux/demux_audio.c (working copy)
-@@ -229,6 +229,8 @@
- ptr += 4;
-
- comment = ptr;
-+ if (&comment[length] < comments || &comment[length] >= &comments[blk_len])
-+ return;
- c = comment[length];
- comment[length] = 0;
-
diff --git a/abs/extra-testing/mplayer/demux_mov_fix_20080129.diff b/abs/extra-testing/mplayer/demux_mov_fix_20080129.diff
deleted file mode 100644
index d83477b..0000000
--- a/abs/extra-testing/mplayer/demux_mov_fix_20080129.diff
+++ /dev/null
@@ -1,45 +0,0 @@
---- libmpdemux/demux_mov.c (revision 24724)
-+++ libmpdemux/demux_mov.c (working copy)
-@@ -173,11 +173,12 @@
- i=trak->chunkmap_size;
- while(i>0){
- --i;
-- for(j=trak->chunkmap[i].first;j<last;j++){
-+ j=FFMAX(trak->chunkmap[i].first, 0);
-+ for(;j<last;j++){
- trak->chunks[j].desc=trak->chunkmap[i].sdid;
- trak->chunks[j].size=trak->chunkmap[i].spc;
- }
-- last=trak->chunkmap[i].first;
-+ last=FFMIN(trak->chunkmap[i].first, trak->chunks_size);
- }
-
- #if 0
-@@ -235,6 +236,8 @@
- s=0;
- for(j=0;j<trak->durmap_size;j++){
- for(i=0;i<trak->durmap[j].num;i++){
-+ if (s >= trak->samples_size)
-+ break;
- trak->samples[s].pts=pts;
- ++s;
- pts+=trak->durmap[j].dur;
-@@ -246,6 +249,8 @@
- for(j=0;j<trak->chunks_size;j++){
- off_t pos=trak->chunks[j].pos;
- for(i=0;i<trak->chunks[j].size;i++){
-+ if (s >= trak->samples_size)
-+ break;
- trak->samples[s].pos=pos;
- mp_msg(MSGT_DEMUX, MSGL_DBG3, "Sample %5d: pts=%8d off=0x%08X size=%d\n",s,
- trak->samples[s].pts,
-@@ -1568,8 +1573,7 @@
- if( udta_len>udta_size)
- udta_len=udta_size;
- {
-- char dump[udta_len-4];
-- stream_read(demuxer->stream, (char *)&dump, udta_len-4-4);
-+ stream_skip(demuxer->stream, udta_len-4-4);
- udta_size -= udta_len;
- }
- }
diff --git a/abs/extra-testing/mplayer/mplayer_desktop.patch b/abs/extra-testing/mplayer/mplayer_desktop.patch
new file mode 100644
index 0000000..7fb2bba
--- /dev/null
+++ b/abs/extra-testing/mplayer/mplayer_desktop.patch
@@ -0,0 +1,11 @@
+--- MPlayer-1.0rc2.orig/etc/mplayer.desktop 2008-11-17 02:09:22.000000000 +0200
++++ MPlayer-1.0rc2/etc/mplayer.desktop 2008-11-17 02:09:33.000000000 +0200
+@@ -10,7 +10,7 @@
+ Comment[it]=Lettore multimediale
+ Icon=mplayer.xpm
+ TryExec=gmplayer
+-Exec=gmplayer %U
++Exec=gmplayer %F
+ Terminal=false
+ Categories=GTK;AudioVideo;Audio;Video;Player;TV;
+ MimeType=application/ogg;application/x-ogg;application/sdp;application/smil;application/x-smil;application/streamingmedia;application/x-streamingmedia;application/vnd.rn-realmedia;application/vnd.rn-realmedia-vbr;audio/aac;audio/x-aac;audio/m4a;audio/x-m4a;audio/mp1;audio/x-mp1;audio/mp2;audio/x-mp2;audio/mp3;audio/x-mp3;audio/mpeg;audio/x-mpeg;audio/mpegurl;audio/x-mpegurl;audio/mpg;audio/x-mpg;audio/rn-mpeg;audio/scpls;audio/x-scpls;audio/vnd.rn-realaudio;audio/wav;audio/x-pn-windows-pcm;audio/x-realaudio;audio/x-pn-realaudio;audio/x-ms-wma;audio/x-pls;audio/x-wav;video/mpeg;video/x-mpeg;video/x-mpeg2;video/msvideo;video/x-msvideo;video/quicktime;video/vnd.rn-realvideo;video/x-ms-afs;video/x-ms-asf;video/x-ms-wmv;video/x-ms-wmx;video/x-ms-wvxvideo;video/x-avi;video/x-fli;video/x-theora;video/x-matroska;
diff --git a/abs/extra-testing/mplayer/stream_cddb_fix_20080120.diff b/abs/extra-testing/mplayer/stream_cddb_fix_20080120.diff
deleted file mode 100644
index 45f7226..0000000
--- a/abs/extra-testing/mplayer/stream_cddb_fix_20080120.diff
+++ /dev/null
@@ -1,32 +0,0 @@
---- stream/stream_cddb.c (revision 24724)
-+++ stream/stream_cddb.c (working copy)
-@@ -53,6 +53,7 @@
- #include "version.h"
- #include "stream.h"
- #include "network.h"
-+#include "libavutil/intreadwrite.h"
-
- #define DEFAULT_FREEDB_SERVER "freedb.freedb.org"
- #define DEFAULT_CACHE_DIR "/.cddb/"
-@@ -453,8 +454,9 @@
- } else {
- len = ptr2-ptr+1;
- }
-+ len = FFMIN(sizeof(album_title) - 1, len);
- strncpy(album_title, ptr, len);
-- album_title[len-2]='\0';
-+ album_title[len]='\0';
- }
- mp_msg(MSGT_DEMUX, MSGL_STATUS, MSGTR_MPDEMUX_CDDB_ParseOKFoundAlbumTitle, album_title);
- return 0;
-@@ -490,8 +492,9 @@
- } else {
- len = ptr2-ptr+1;
- }
-+ len = FFMIN(sizeof(album_title) - 1, len);
- strncpy(album_title, ptr, len);
-- album_title[len-2]='\0';
-+ album_title[len]='\0';
- }
- mp_msg(MSGT_DEMUX, MSGL_STATUS, MSGTR_MPDEMUX_CDDB_ParseOKFoundAlbumTitle, album_title);
- return cddb_request_titles(cddb_data);
diff --git a/abs/extra-testing/mplayer/url_fix_20080120.diff b/abs/extra-testing/mplayer/url_fix_20080120.diff
deleted file mode 100644
index a073589..0000000
--- a/abs/extra-testing/mplayer/url_fix_20080120.diff
+++ /dev/null
@@ -1,10 +0,0 @@
---- stream/url.c (revision 24724)
-+++ stream/url.c (working copy)
-@@ -328,6 +328,7 @@
- }
- }
-
-+ tmp = NULL;
- while(i < len) {
- // look for the next char that must be kept
- for (j=i;j<len;j++) {