summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/policykit-gnome
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-03 07:56:23 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-03 07:56:23 (GMT)
commit0ce6326882d1ef6b45955ce0af948aa3da22bc07 (patch)
tree6ef646f87190a95deea7641df53c6ee5396c900c /abs/extra-testing/policykit-gnome
parent907606040ebd98338b939452ee37698b62718820 (diff)
downloadlinhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.zip
linhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.tar.gz
linhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.tar.bz2
Added support for Miro.
Diffstat (limited to 'abs/extra-testing/policykit-gnome')
-rw-r--r--abs/extra-testing/policykit-gnome/PKGBUILD32
-rw-r--r--abs/extra-testing/policykit-gnome/policykit-gnome.install23
2 files changed, 55 insertions, 0 deletions
diff --git a/abs/extra-testing/policykit-gnome/PKGBUILD b/abs/extra-testing/policykit-gnome/PKGBUILD
new file mode 100644
index 0000000..e6a7d9c
--- /dev/null
+++ b/abs/extra-testing/policykit-gnome/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: onestep_ua <onestep@ukr.net>
+
+pkgname=policykit-gnome
+pkgver=0.9.2
+pkgrel=2
+pkgdesc="PolicyKit integration for the GNOME desktop"
+arch=('i686' 'x86_64')
+url="http://hal.freedesktop.org/docs/PolicyKit-gnome/"
+license=('GPL')
+depends=('gconf>=2.24.0')
+makedepends=('intltool' 'gtk-doc' 'gnome-doc-utils>=0.14.0')
+options=(!emptydirs !libtool)
+install=${pkgname}.install
+source=(http://hal.freedesktop.org/releases/PolicyKit-gnome-${pkgver}.tar.bz2)
+md5sums=('fc478b168d0c926a9766b0b415ff4bbf')
+
+build() {
+ cd "${srcdir}/PolicyKit-gnome-${pkgver}"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/PolicyKit \
+ --disable-gtk-doc \
+ --disable-examples || return 1
+ make || return 1
+ make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="${pkgdir}" install || return 1
+
+ install -m 755 -d "${pkgdir}/usr/share/gconf/schemas"
+ gconf-merge-schema "${pkgdir}/usr/share/gconf/schemas/${pkgname}.schemas" ${pkgdir}/etc/gconf/schemas/*.schemas || return 1
+ rm -f ${pkgdir}/etc/gconf/schemas/*.schemas
+}
diff --git a/abs/extra-testing/policykit-gnome/policykit-gnome.install b/abs/extra-testing/policykit-gnome/policykit-gnome.install
new file mode 100644
index 0000000..e2593d3
--- /dev/null
+++ b/abs/extra-testing/policykit-gnome/policykit-gnome.install
@@ -0,0 +1,23 @@
+pkgname=policykit-gnome
+
+## arg 1: the new package version
+post_install() {
+ usr/sbin/gconfpkg --install ${pkgname}
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+pre_upgrade() {
+ pre_remove $1
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+## arg 1: the old package version
+pre_remove() {
+ usr/sbin/gconfpkg --uninstall ${pkgname}
+}