summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/postgresql
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/extra-testing/postgresql
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/extra-testing/postgresql')
-rw-r--r--abs/extra-testing/postgresql/PKGBUILD79
-rw-r--r--abs/extra-testing/postgresql/build.patch11
-rwxr-xr-xabs/extra-testing/postgresql/postgresql59
-rw-r--r--abs/extra-testing/postgresql/postgresql.confd4
-rw-r--r--abs/extra-testing/postgresql/postgresql.pam3
5 files changed, 0 insertions, 156 deletions
diff --git a/abs/extra-testing/postgresql/PKGBUILD b/abs/extra-testing/postgresql/PKGBUILD
deleted file mode 100644
index 1fda9a4..0000000
--- a/abs/extra-testing/postgresql/PKGBUILD
+++ /dev/null
@@ -1,79 +0,0 @@
-# $Id: PKGBUILD 27762 2009-02-25 16:29:49Z douglas $
-# Maintainer: Paul Mattal <paul@archlinux.org>
-
-pkgname=postgresql
-pkgver=8.3.6
-pkgrel=1
-pkgdesc="A sophisticated object-relational DBMS"
-arch=(i686 x86_64)
-license=('BSD')
-backup=('etc/conf.d/postgresql' '/etc/pam.d/postgresql')
-url="http://www.postgresql.org/"
-depends=("postgresql-libs>=$pkgver" "libxml2")
-options=('!makeflags')
-source=(ftp://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2 \
- postgresql postgresql.confd build.patch postgresql.pam)
-
-build() {
- cd ${startdir}/src/$pkgname-$pkgver || return 1
-
- # patch to remove regress/test make target (won't build with it present)
- patch -Np1 -i ../build.patch || return 1
-
- # configure
- ./configure --prefix=/usr --mandir=/usr/share/man \
- --with-docdir=/usr/share/doc --with-openssl \
- --datadir=/usr/share/postgresql --with-pam --with-libxml || return 1
-
- sed -i -e '/interfaces/d' src/Makefile || return 1
-
- # build
- make || return 1
-
- # install
- make DESTDIR=${startdir}/pkg install || return 1
-
- (
- cd contrib/adminpack;
- make || return 1;
- make DESTDIR=${startdir}/pkg install || return 1;
- );
-
-
- # clean up unneeded installed items
- rm -rf $startdir/pkg/usr/include/postgresql/internal || return 1
- rm -rf $startdir/pkg/usr/include/libpq || return 1
- # the below line is expected to produce an error; fix this one day
- rm -f $startdir/pkg/usr/include/*
- rm -f $startdir/pkg/usr/bin/pg_config || return 1
-
- # Maintaining the lib below because of qt
- #rm -f $startdir/pkg/usr/lib/libpgport.a || return 1
-
- # install launch script
- install -D -m755 ../postgresql $startdir/pkg/etc/rc.d/postgresql \
- || return 1
-
- # install license
- install -D -m644 COPYRIGHT $startdir/pkg/usr/share/licenses/$pkgname/LICENSE || return 1
-
- # install conf file
- install -D -m644 $startdir/src/postgresql.confd \
- $startdir/pkg/etc/conf.d/postgresql || return 1
-
- install -D -m644 $startdir/src/postgresql.pam \
- $startdir/pkg/etc/pam.d/postgresql
-
- chown root:root $startdir/pkg/usr/share/doc/postgresql/html/*
-}
-
-md5sums=('4f8c67d802bd03b5b844e268bba7d44a'
- '7d8ea2abb6a8cdacf35604bda659a34a'
- 'df6ddf9e2ab4700a3415f17c0f4f4172'
- '4d74f4227dc5e12bf95b3490758d86c9'
- '96f82c38f3f540b53f3e5144900acf17')
-md5sums=('4f8c67d802bd03b5b844e268bba7d44a'
- '7d8ea2abb6a8cdacf35604bda659a34a'
- 'df6ddf9e2ab4700a3415f17c0f4f4172'
- '4d74f4227dc5e12bf95b3490758d86c9'
- '96f82c38f3f540b53f3e5144900acf17')
diff --git a/abs/extra-testing/postgresql/build.patch b/abs/extra-testing/postgresql/build.patch
deleted file mode 100644
index c8f665d..0000000
--- a/abs/extra-testing/postgresql/build.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Naur postgresql-8.2.3-orig/src/Makefile postgresql-8.2.3/src/Makefile
---- postgresql-8.2.3-orig/src/Makefile 2006-06-22 16:50:35.000000000 -0700
-+++ postgresql-8.2.3/src/Makefile 2007-03-05 10:46:24.000000000 -0800
-@@ -23,7 +23,6 @@
- $(MAKE) -C bin $@
- $(MAKE) -C pl $@
- $(MAKE) -C makefiles $@
-- $(MAKE) -C test/regress $@
-
- install: install-local
-
diff --git a/abs/extra-testing/postgresql/postgresql b/abs/extra-testing/postgresql/postgresql
deleted file mode 100755
index c6aedfb..0000000
--- a/abs/extra-testing/postgresql/postgresql
+++ /dev/null
@@ -1,59 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-. /etc/conf.d/postgresql
-
-case "$1" in
- start)
- stat_busy "Starting PostgreSQL"
- # initialization
- if [ ! `egrep '^postgres:' /etc/group` ]; then
- stat_busy "Adding postgres group"
- groupadd -g 88 postgres
- stat_done
- fi
- if [ ! `egrep '^postgres:' /etc/passwd` ]; then
- stat_busy "Adding postgres user"
- useradd -u 88 -g postgres -d $PGROOT -s /bin/bash postgres
- [ -d $PGROOT ] && chown -R postgres.postgres $PGROOT
- stat_done
- fi
- if [ ! -d $PGROOT ]; then
- mkdir -p $PGROOT/data && chown postgres.postgres $PGROOT/data
- su - postgres -c "/usr/bin/initdb -D $PGROOT/data"
- fi
- if [ ! -e /var/log/postgresql.log ]; then
- touch /var/log/postgresql.log
- chown postgres /var/log/postgresql.log
- fi
- # start the process
- su - postgres -c \
- "/usr/bin/pg_ctl -D $PGROOT/data -l /var/log/postgresql.log -W start"
- if [ $? -gt 0 ]; then
- stat_fail
- else
- add_daemon postgresql
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping PostgreSQL"
- su - postgres -c \
- "/usr/bin/pg_ctl -D $PGROOT/data -l /var/log/postgresql.log -w stop"
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm_daemon postgresql
- stat_done
- fi
- ;;
- restart)
- $0 stop
- sleep 3
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
-esac
-exit 0
diff --git a/abs/extra-testing/postgresql/postgresql.confd b/abs/extra-testing/postgresql/postgresql.confd
deleted file mode 100644
index 7bbf016..0000000
--- a/abs/extra-testing/postgresql/postgresql.confd
+++ /dev/null
@@ -1,4 +0,0 @@
-#
-# Parameters to be passed to postgresql
-#
-PGROOT="/var/lib/postgres" \ No newline at end of file
diff --git a/abs/extra-testing/postgresql/postgresql.pam b/abs/extra-testing/postgresql/postgresql.pam
deleted file mode 100644
index 53724d1..0000000
--- a/abs/extra-testing/postgresql/postgresql.pam
+++ /dev/null
@@ -1,3 +0,0 @@
-auth required pam_unix.so
-account required pam_unix.so
-session required pam_unix.so