summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/printproto/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-05-02 08:55:02 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-05-02 08:55:02 (GMT)
commit25e39d3ad6f66fad48c0183dd568e2fbfded5ca2 (patch)
tree0d8bb2c9bca3a20c3ac2067ff7453c0aae5e8a3e /abs/extra-testing/printproto/PKGBUILD
parent1f70585d4abb80a2cc47316ab2b4851637939997 (diff)
downloadlinhes_pkgbuild-25e39d3ad6f66fad48c0183dd568e2fbfded5ca2.zip
linhes_pkgbuild-25e39d3ad6f66fad48c0183dd568e2fbfded5ca2.tar.gz
linhes_pkgbuild-25e39d3ad6f66fad48c0183dd568e2fbfded5ca2.tar.bz2
Latest version or newly required deps for various packages.
Diffstat (limited to 'abs/extra-testing/printproto/PKGBUILD')
-rw-r--r--abs/extra-testing/printproto/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/abs/extra-testing/printproto/PKGBUILD b/abs/extra-testing/printproto/PKGBUILD
new file mode 100644
index 0000000..11595db
--- /dev/null
+++ b/abs/extra-testing/printproto/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 567 2008-04-21 09:43:18Z alexander $
+# Maintainer: Alexander Baldeck <alexander@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+pkgname=printproto
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="X11 print extension wire protocol"
+arch=(i686 x86_64)
+license=('custom')
+url="http://xorg.freedesktop.org/"
+source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2)
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=${startdir}/pkg install || return 1
+
+ install -D -m644 ${startdir}/src/${pkgname}-${pkgver}/COPYING \
+ ${startdir}/pkg/usr/share/licenses/${pkgname}/COPYING
+}
+md5sums=('7321847a60748b4d2f1fa16db4b6ede8')