summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/rrd_stats/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-06-15 05:03:27 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-06-15 05:03:27 (GMT)
commitb760ec370e5f2265ee619e394d44b7fd8b3e2346 (patch)
treecee4f10f2f9f454cdd13cbda4c240ebc49df1885 /abs/extra-testing/rrd_stats/PKGBUILD
parent20a5899db76084e118e8ec9f990dc58d1c467718 (diff)
downloadlinhes_pkgbuild-b760ec370e5f2265ee619e394d44b7fd8b3e2346.zip
linhes_pkgbuild-b760ec370e5f2265ee619e394d44b7fd8b3e2346.tar.gz
linhes_pkgbuild-b760ec370e5f2265ee619e394d44b7fd8b3e2346.tar.bz2
rrd_stats: add to repo
ref FS#146
Diffstat (limited to 'abs/extra-testing/rrd_stats/PKGBUILD')
-rw-r--r--abs/extra-testing/rrd_stats/PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/abs/extra-testing/rrd_stats/PKGBUILD b/abs/extra-testing/rrd_stats/PKGBUILD
new file mode 100644
index 0000000..8e027d5
--- /dev/null
+++ b/abs/extra-testing/rrd_stats/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=rrd_stats
+pkgver=1
+pkgrel=9
+pkgdesc="graph system stats"
+arch=('i686' 'x86_64')
+url=""
+license=('GPL')
+source=(rrd_stats.tgz)
+depends=('hddtemp' 'sysstat' 'xmbmon' 'rrdtool' 'perl' 'local-website')
+backup=('etc/rrdsettings.cfg' 'data/srv/httpd/htdocs/index-rrd.html')
+install=rrd_stats.install
+build() {
+ cd $startdir/src/$pkgname
+ cp -a * $startdir/pkg
+ mkdir -p $startdir/pkg/var/lib/rrd
+ echo "RRD files are used by rrd_stats" > $startdir/pkg/var/lib/rrd/README
+ mv $startdir/pkg/data/srv/httpd/htdocs/rrd/index.html $startdir/pkg/data/srv/httpd/htdocs/rrd/index-rrd.html
+ chown -R http:users $startdir/pkg/data/srv/httpd
+ chmod -R 755 $startdir/pkg/data/srv/httpd
+}