summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/sdl_sound/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2008-12-11 01:30:53 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2008-12-11 01:30:53 (GMT)
commit8417e5e3b118ed9e12563a3d4fceeb38b9e73d4f (patch)
tree99edff3d756441a12087ecd5053d9ca60536beff /abs/extra-testing/sdl_sound/PKGBUILD
parente649efa24662af962e6cbd7b9ece1bdd8f6a9340 (diff)
downloadlinhes_pkgbuild-8417e5e3b118ed9e12563a3d4fceeb38b9e73d4f.zip
linhes_pkgbuild-8417e5e3b118ed9e12563a3d4fceeb38b9e73d4f.tar.gz
linhes_pkgbuild-8417e5e3b118ed9e12563a3d4fceeb38b9e73d4f.tar.bz2
Deps for emulators and Miro.
Diffstat (limited to 'abs/extra-testing/sdl_sound/PKGBUILD')
-rw-r--r--abs/extra-testing/sdl_sound/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/extra-testing/sdl_sound/PKGBUILD b/abs/extra-testing/sdl_sound/PKGBUILD
new file mode 100644
index 0000000..87885c2
--- /dev/null
+++ b/abs/extra-testing/sdl_sound/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Maintainer: dorphell <dorphell@archlinux.org>
+pkgname=sdl_sound
+pkgver=1.0.1
+pkgrel=7
+pkgdesc="A library to decode several popular sound file formats, such as .WAV and .MP3"
+arch=(i686 x86_64)
+depends=('sdl' 'libmikmod' 'libvorbis' 'flac>=1.1.4' 'speex')
+source=(http://icculus.org/SDL_sound/downloads/SDL_sound-$pkgver.tar.gz flac.patch)
+url="http://icculus.org/SDL_sound/"
+
+build() {
+ cd $startdir/src/SDL_sound-$pkgver
+ patch -Np1 -i ../flac.patch || return 1
+ aclocal
+ autoconf
+ automake --foreign
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+ # libtoolslay
+ find $startdir/pkg -name '*.la' -exec rm {} \;
+}
+md5sums=('49e197ef7c8ab623d0640dc74be43160' '302aa9dc94cc71dd3339ca3177d36e1c')