summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/thunar/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-05 14:38:10 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-05 14:38:10 (GMT)
commitee33ddf6f3657ff6384de9c6e517511f0427ffc7 (patch)
treec02a8afa5bdd1099494f7d436a58dec4bf086b12 /abs/extra-testing/thunar/PKGBUILD
parentd6049e8a38b8babf070b6f2183c336334ed97fd9 (diff)
downloadlinhes_pkgbuild-ee33ddf6f3657ff6384de9c6e517511f0427ffc7.zip
linhes_pkgbuild-ee33ddf6f3657ff6384de9c6e517511f0427ffc7.tar.gz
linhes_pkgbuild-ee33ddf6f3657ff6384de9c6e517511f0427ffc7.tar.bz2
Goodbye chroot-devel.
All things chroot-devel have been moved and split between core and extra
Diffstat (limited to 'abs/extra-testing/thunar/PKGBUILD')
-rw-r--r--abs/extra-testing/thunar/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/extra-testing/thunar/PKGBUILD b/abs/extra-testing/thunar/PKGBUILD
new file mode 100644
index 0000000..05c262e
--- /dev/null
+++ b/abs/extra-testing/thunar/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 28211 2009-02-28 11:12:20Z andyrtr $
+# Maintainer: tobias <tobias funnychar archlinux.org>
+# Contributor: Andrew Simmons <andrew.simmons@gmail.com>
+
+pkgname=thunar
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="new modern file manager for Xfce"
+arch=(i686 x86_64)
+license=('GPL2' 'LGPL2')
+url="http://thunar.xfce.org"
+groups=('xfce4')
+depends=('desktop-file-utils' 'libexif>=0.6.17' 'hicolor-icon-theme'
+'tango-icon-theme' )
+makedepends=('intltool' 'pkgconfig')
+optdepends=('gamin: a fam replacement to make thunar monitor changes to files on the fly')
+options=('!libtool')
+install=${pkgname}.install
+source=(http://www.xfce.org/archive/xfce-4.6.0/src/Thunar-${pkgver}.tar.bz2)
+md5sums=('468c240a4f65a217ec2b6132e85cd84e')
+
+build() {
+ cd ${srcdir}/Thunar-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
+ --localstatedir=/var --disable-static \
+ --disable-gnome-thumbnailers --enable-exif --enable-pcre --disable-fam
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+ sed -i 's:x-directory/gnome-default-handler;::' \
+ ${pkgdir}/usr/share/applications/Thunar-folder-handler.desktop
+}