summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/unison/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-14 17:59:21 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-14 17:59:21 (GMT)
commitba58f41e5bfbe2b8c589bb00d68cfeec888e48e9 (patch)
tree3d98bf06368dc587b2cf13fbb26890acae06ace3 /abs/extra-testing/unison/PKGBUILD
parent0c9c49881bbaf1fa27ab080776e4e372f1b8488f (diff)
downloadlinhes_pkgbuild-ba58f41e5bfbe2b8c589bb00d68cfeec888e48e9.zip
linhes_pkgbuild-ba58f41e5bfbe2b8c589bb00d68cfeec888e48e9.tar.gz
linhes_pkgbuild-ba58f41e5bfbe2b8c589bb00d68cfeec888e48e9.tar.bz2
Missing ocaml, needed for unison.
Moving usion to extra-testing.
Diffstat (limited to 'abs/extra-testing/unison/PKGBUILD')
-rw-r--r--abs/extra-testing/unison/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/extra-testing/unison/PKGBUILD b/abs/extra-testing/unison/PKGBUILD
new file mode 100644
index 0000000..b1efa5b
--- /dev/null
+++ b/abs/extra-testing/unison/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+#Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=unison
+pkgver=2.27.57
+pkgrel=1
+pkgdesc="Unison is a file-synchronization tool"
+arch=(i686 x86_64)
+license=('GPL2')
+url="http://www.cis.upenn.edu/~bcpierce/unison"
+depends=('glibc')
+#makedepends=('ocaml' 'lablgtk' 'lablgtk2' 'imagemagick')
+makedepends=('ocaml' )
+source=(http://www.cis.upenn.edu/~bcpierce/unison/download/releases/stable/$pkgname-$pkgver.tar.gz \
+ $pkgname.desktop)
+options=(!makeflags)
+install=unison.install
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ CFLAGS=""
+ make clean
+ make UISTYLE=text DEBUGGING=false THREADS=true || return 1
+ mkdir -p $startdir/pkg/usr/bin
+ install -Dm755 unison $startdir/pkg/usr/bin/unison
+}
+md5sums=('4ba0a3e4bf4b4ad0c063f86391371f78'
+ '2daecba7705455a8e4b769e48b059872')