summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/unixodbc/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-15 18:51:07 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-15 18:51:07 (GMT)
commit1f8cf166a41c887bf7ad0d86da41beb3d152ba36 (patch)
tree64957a33a55714e5946a2041e8dd13162ebe67e3 /abs/extra-testing/unixodbc/PKGBUILD
parentb03295cc13f34c6bbb185469832d2f33d78beff0 (diff)
downloadlinhes_pkgbuild-1f8cf166a41c887bf7ad0d86da41beb3d152ba36.zip
linhes_pkgbuild-1f8cf166a41c887bf7ad0d86da41beb3d152ba36.tar.gz
linhes_pkgbuild-1f8cf166a41c887bf7ad0d86da41beb3d152ba36.tar.bz2
qt4 package
Diffstat (limited to 'abs/extra-testing/unixodbc/PKGBUILD')
-rw-r--r--abs/extra-testing/unixodbc/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/extra-testing/unixodbc/PKGBUILD b/abs/extra-testing/unixodbc/PKGBUILD
new file mode 100644
index 0000000..b8c2690
--- /dev/null
+++ b/abs/extra-testing/unixodbc/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 9389 2008-08-17 06:44:49Z allan $
+# Maintainer: Judd Vinet <jvinet@zeroflux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=unixodbc
+pkgver=2.2.12
+pkgrel=2
+pkgdesc="ODBC is an open specification for providing application developers with a predictable API with which to access Data Sources"
+arch=(i686 x86_64)
+license=('GPL2')
+url="http://www.unixodbc.org/"
+backup=('etc/odbc.ini' 'etc/odbcinst.ini')
+depends=('readline')
+source=(http://www.unixodbc.org/unixODBC-$pkgver.tar.gz)
+md5sums=('9a116aad4059c31d231b626ffdf1869a')
+
+build() {
+ cd $startdir/src/unixODBC-$pkgver
+ sed -i 's/YY_FLUSH_BUFFER/yy_flush_buffer(YY_CURRENT_BUFFER)/' sqp/lex.l
+ ./configure --prefix=/usr --sysconfdir=/etc --enable-gui=no
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+ find $startdir/pkg -name '*.la' -exec rm {} \;
+}