summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/v4l-dvb-hdpvr/v4l-dvb-hdpvr.install
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-11 18:50:00 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-11 18:50:00 (GMT)
commit3f11fa374c89a6444e75e7ae319a41cefd8d51ab (patch)
treeb46a5e6f3d6cc46f376116f70794da4ca5b1038d /abs/extra-testing/v4l-dvb-hdpvr/v4l-dvb-hdpvr.install
parentbcf5ec3fa5da5bbac9a1eaba782bbcea0278d9b7 (diff)
parentae4a3db9403d07e987efc351701eb5429baff635 (diff)
downloadlinhes_pkgbuild-3f11fa374c89a6444e75e7ae319a41cefd8d51ab.zip
linhes_pkgbuild-3f11fa374c89a6444e75e7ae319a41cefd8d51ab.tar.gz
linhes_pkgbuild-3f11fa374c89a6444e75e7ae319a41cefd8d51ab.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Conflicts: abs/core-testing/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/extra-testing/v4l-dvb-hdpvr/v4l-dvb-hdpvr.install')
-rw-r--r--abs/extra-testing/v4l-dvb-hdpvr/v4l-dvb-hdpvr.install23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra-testing/v4l-dvb-hdpvr/v4l-dvb-hdpvr.install b/abs/extra-testing/v4l-dvb-hdpvr/v4l-dvb-hdpvr.install
new file mode 100644
index 0000000..c87bb82
--- /dev/null
+++ b/abs/extra-testing/v4l-dvb-hdpvr/v4l-dvb-hdpvr.install
@@ -0,0 +1,23 @@
+# arg 1: the new package version
+post_install() {
+ KERNEL_VERSION='2.6.26-ARCH'
+ depmod -ae -v $KERNEL_VERSION > /dev/null 2>&1
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ KERNEL_VERSION='2.6.26-ARCH'
+ depmod -ae -v $KERNEL_VERSION > /dev/null 2>&1
+
+}
+
+# arg 1: the old package version
+post_remove() {
+ KERNEL_VERSION='2.6.26-ARCH'
+ depmod -ae -v $KERNEL_VERSION > /dev/null 2>&1
+}
+
+op=$1
+shift
+$op $*