summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/webmin/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-19 06:08:56 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-19 06:08:56 (GMT)
commit4d8cb4b57c9706028750560bf9a56fb44f90e4d2 (patch)
tree820a86c34fafeb417f37311dd8a8014c1a037d51 /abs/extra-testing/webmin/PKGBUILD
parentec31c0cf3c25a0b824229a85ece5cdec2e7d47df (diff)
downloadlinhes_pkgbuild-4d8cb4b57c9706028750560bf9a56fb44f90e4d2.zip
linhes_pkgbuild-4d8cb4b57c9706028750560bf9a56fb44f90e4d2.tar.gz
linhes_pkgbuild-4d8cb4b57c9706028750560bf9a56fb44f90e4d2.tar.bz2
Implements webmin in LinHES. Added run to allow for control w/ runit.
Diffstat (limited to 'abs/extra-testing/webmin/PKGBUILD')
-rw-r--r--abs/extra-testing/webmin/PKGBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/abs/extra-testing/webmin/PKGBUILD b/abs/extra-testing/webmin/PKGBUILD
index f7fc020..1ce083e 100644
--- a/abs/extra-testing/webmin/PKGBUILD
+++ b/abs/extra-testing/webmin/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
pkgname=webmin
pkgver=1.441
-pkgrel=1
+pkgrel=2
pkgdesc="a web-based interface for system administration"
arch=(i686 x86_64)
license=('custom:webmin')
@@ -86,7 +86,8 @@ install=webmin.install
source=(http://downloads.sourceforge.net/sourceforge/webadmin/$pkgname-$pkgver.tar.gz
ftp://ftp.archlinux.org/other/webmin/webmin-config.tar.bz2
ftp://ftp.archlinux.org/other/webmin/webmin-pacman.tar.bz2
- webmin.rc)
+ webmin.rc
+ run)
build() {
# NOTE: USE --asroot build option to avoid fakeroot error!
@@ -192,8 +193,11 @@ build() {
sed -i 's:^pidfile=.*$:pidfile=/var/run/webmin.pid:' $startdir/pkg/etc/webmin/miniserv.conf
find $startdir/pkg/etc/webmin -type f -exec sed -i "s:$startdir/pkg::g" {} \;
- # make it only accessible by localhost
- echo 'allow=127.0.0.1' >> $startdir/pkg/etc/webmin/miniserv.conf
+ # make it only accessible by localhost and private networks
+ echo 'allow=127.0.0.1 192.168. 172.16. 10.' >> $startdir/pkg/etc/webmin/miniserv.conf
+
+ #Let not fork this bad boy. We need to control it w/ runit.
+ echo 'nofork=1' >> $startdir/pkg/etc/webmin/miniserv.conf
# install pacman menu
cd $startdir/src/webmin-pacman/config
@@ -206,8 +210,13 @@ build() {
rm -r $startdir/pkg/tmp
# install license
install -m 644 -D $startdir/src/$pkgname-$pkgver/LICENCE $startdir/pkg/usr/share/licenses/webmin/LICENCE
+
+ #runit
+ mkdir -p $startdir/pkg/etc/sv/webmin/supervise
+ install -D -m 755 $startdir/src/run $startdir/pkg/etc/sv/webmin
}
md5sums=('b841af1b1a9f78795814ce8211e6ad81'
'da6bea412a5be8cf82a813078fec5847'
'4cf1139093ea59044be42a4f173fb8aa'
- '0673e51af0e81418b4a6c1e205f7e5cd')
+ '0673e51af0e81418b4a6c1e205f7e5cd'
+ 'bc578b249e2090deb84119a626c53c48')