summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/xfsdump/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-01 23:40:08 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-01 23:40:08 (GMT)
commit8bc928907e616b695413f9dbb1f6aaa56d56cc33 (patch)
tree813f5edb45a9bb15220820dac697d77a0615c360 /abs/extra-testing/xfsdump/PKGBUILD
parent3d5a6dbf75eff39ad3e417aeb9c606a351e632e0 (diff)
downloadlinhes_pkgbuild-8bc928907e616b695413f9dbb1f6aaa56d56cc33.zip
linhes_pkgbuild-8bc928907e616b695413f9dbb1f6aaa56d56cc33.tar.gz
linhes_pkgbuild-8bc928907e616b695413f9dbb1f6aaa56d56cc33.tar.bz2
update xfs programs and add xfsdump
Diffstat (limited to 'abs/extra-testing/xfsdump/PKGBUILD')
-rw-r--r--abs/extra-testing/xfsdump/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/extra-testing/xfsdump/PKGBUILD b/abs/extra-testing/xfsdump/PKGBUILD
new file mode 100644
index 0000000..1d40228
--- /dev/null
+++ b/abs/extra-testing/xfsdump/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 26569 2009-02-09 18:40:22Z paul $
+# Maintainer: judd <jvinet@zeroflux.org>
+pkgname=xfsdump
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Additional XFS filesystem utilities"
+arch=(i686 x86_64)
+license=('LGPL')
+url="http://oss.sgi.com/projects/xfs/"
+depends=('xfsprogs>=3.0.0' 'attr>=2.4.39' 'acl>=2.2.45' 'dmapi')
+options=('!makeflags')
+source=(ftp://oss.sgi.com/projects/xfs/cmd_tars/xfsdump-${pkgver}.tar.gz)
+md5sums=('')
+options=(!emptydirs)
+
+build() {
+ cd $startdir/src/xfsdump-$pkgver
+ autoconf
+ ./configure --prefix=/usr
+ make || return 1
+ make prefix=$startdir/pkg/usr install
+ # fixes
+ rm -f $startdir/pkg/usr/lib/*.la
+ rm -f $startdir/pkg/usr/bin/{xfsdump,xfsrestore}
+}